Remove use of AGL_APP_REVISION 92/27692/1
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Wed, 29 Jun 2022 18:21:16 +0000 (20:21 +0200)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Wed, 29 Jun 2022 18:21:16 +0000 (20:21 +0200)
We did use the variable AGL_APP_REVISION to change between the HEAD of the branch
via  to the fixed tag at release time (regs/tags/xyz) .

While this worked well previously, it turns out that bitbake will query git every time
it runs for either  or tags likewise. For tags it cannot trust whatever is known locally
is actually the latest tags as there can be force pushed tags.

To fix this we use a well-defined SRCREV for apps/* in the same way
as we do it for src/* .

Bug-AGL: SPEC-4455
Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Change-Id: I97fc125d40b36b7ac5e069018a8973384f61d0b7

17 files changed:
recipes-demo/camera-gstreamer/camera-gstreamer_git.bb
recipes-demo/cluster-dashboard/cluster-dashboard_git.bb
recipes-demo/cluster-gauges-qtcompositor/cluster-gauges-qtcompositor_git.bb
recipes-demo/cluster-receiver/cluster-receiver_git.bb
recipes-demo/cluster-receiver/qt-cluster-receiver_git.bb
recipes-demo/dashboard/dashboard_git.bb
recipes-demo/homescreen/homescreen_git.bb
recipes-demo/hvac/hvac_git.bb
recipes-demo/launcher/launcher_git.bb
recipes-demo/mediaplayer/mediaplayer_git.bb
recipes-demo/messaging/messaging_git.bb
recipes-demo/navigation/ondemandnavi_git.bb
recipes-demo/navigation/tbtnavi_git.bb
recipes-demo/phone/phone_git.bb
recipes-demo/radio/radio_git.bb
recipes-demo/settings/settings_git.bb
scripts/run-yocto-check-layer-all-layers.sh

index e9fa575..f0163df 100644 (file)
@@ -14,7 +14,7 @@ DEPENDS = " \
 PV = "1.0+git${SRCPV}"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/camera-gstreamer;protocol=https;branch=${AGL_BRANCH}"
-SRCREV  = "${AGL_APP_REVISION}"
+SRCREV  = "30c275c5c87b9d4f0bc3b0e0e3175775d3738319"
 
 S  = "${WORKDIR}/git"
 
index 0f45d8f..b00f1ec 100644 (file)
@@ -20,7 +20,7 @@ PV = "1.0+git${SRCPV}"
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-cluster-demo-dashboard;protocol=https;branch=${AGL_BRANCH} \
            file://cluster-dashboard.service \
 "
-SRCREV  = "${AGL_APP_REVISION}"
+SRCREV  = "00fa784cdb2570f742511820b885b1c3e18b6d01"
 
 S  = "${WORKDIR}/git"
 
index 74f87ac..166a504 100644 (file)
@@ -15,7 +15,7 @@ SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-cluster-demo-gauges;
            file://cluster-gauges-qtcompositor.service \
 "
 
-SRCREV  = "${AGL_APP_REVISION}"
+SRCREV  = "23eaf7da1f7d252aefddf9e41e52c745b7433b50"
 
 S  = "${WORKDIR}/git"
 
index 3b1dd6a..c022212 100644 (file)
@@ -17,7 +17,7 @@ PV = "1.0+git${SRCPV}"
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-cluster-demo-receiver;protocol=https;branch=${AGL_BRANCH} \
            file://cluster-receiver.service \
 "
-SRCREV  = "${AGL_APP_REVISION}"
+SRCREV  = "be95c2a9466d03dda01cb882a70458aac81f36e4"
 
 S  = "${WORKDIR}/git"
 
index d43ab43..8d8908c 100644 (file)
@@ -19,7 +19,7 @@ PV = "1.0+git${SRCPV}"
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-qt-cluster-demo-receiver;protocol=https;branch=${AGL_BRANCH} \
            file://qt-cluster-receiver.service \
 "
-SRCREV  = "${AGL_APP_REVISION}"
+SRCREV  = "b5622ce91307589b03ad5d903214b47ff2277e48"
 
 S  = "${WORKDIR}/git"
 
index 60ff637..509b68b 100644 (file)
@@ -14,7 +14,7 @@ DEPENDS = " \
 PV = "2.0+git${SRCPV}"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/dashboard;protocol=https;branch=${AGL_BRANCH}"
-SRCREV  = "${AGL_APP_REVISION}"
+SRCREV  = "3fc84a0a674fa532f6aded100cf2beb3d0cf1f83"
 
 S = "${WORKDIR}/git"
 
index c455678..d21711c 100644 (file)
@@ -23,7 +23,7 @@ PV = "1.0+git${SRCPV}"
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/homescreen;protocol=https;branch=${AGL_BRANCH} \
            file://homescreen.service \
 "
-SRCREV = "${AGL_APP_REVISION}"
+SRCREV = "c35327b02a28a83536450a664326d183662e89e1"
 
 S = "${WORKDIR}/git"
 
index ffa1234..c518708 100644 (file)
@@ -17,7 +17,7 @@ DEPENDS = " \
 PV = "2.0+git${SRCPV}"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/hvac;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "${AGL_APP_REVISION}"
+SRCREV = "c173b5b5fbdb9013304ad62e0dc8f8bb9a072e7d"
 
 S = "${WORKDIR}/git"
 
index 04f34da..3c27fab 100644 (file)
@@ -25,7 +25,7 @@ SRC_URI = " \
         git://gerrit.automotivelinux.org/gerrit/apps/launcher;protocol=https;branch=${AGL_BRANCH} \
         file://launcher.service \
         "
-SRCREV  = "${AGL_APP_REVISION}"
+SRCREV  = "fd578508fe8f59a0bf11916ea99561125dcfc4ba"
 
 S       = "${WORKDIR}/git"
 
index 31d1020..aca107b 100644 (file)
@@ -11,7 +11,7 @@ DEPENDS = "qtquickcontrols2 libqtappfw"
 PV = "2.0+git${SRCPV}"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/mediaplayer;protocol=https;branch=${AGL_BRANCH}"
-SRCREV  = "${AGL_APP_REVISION}"
+SRCREV  = "d53efa6bca224f2c6bec8e7b14b1dff7f12a2d03"
 
 S  = "${WORKDIR}/git"
 
index 0da2c9e..31ca7ce 100644 (file)
@@ -11,7 +11,7 @@ DEPENDS = "qtquickcontrols2 libqtappfw"
 PV = "1.0+git${SRCPV}"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/messaging;protocol=https;branch=${AGL_BRANCH}"
-SRCREV  = "${AGL_APP_REVISION}"
+SRCREV  = "e58b0382de8e665d64b8e3486022a6bcb0572823"
 
 S  = "${WORKDIR}/git"
 
index 3b9fce4..c89ddeb 100644 (file)
@@ -11,7 +11,7 @@ DEPENDS = "qtquickcontrols2 qtlocation libqtappfw"
 PV = "2.0+git${SRCPV}"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/ondemandnavi;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "${AGL_APP_REVISION}"
+SRCREV = "1593664d2f17ab563c7ad81215696b1ac6a3bd7b"
 
 S = "${WORKDIR}/git"
 
index 5981cc5..d052b67 100644 (file)
@@ -23,7 +23,7 @@ DEPENDS = " \
 PV = "2.0+git${SRCPV}"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/tbtnavi;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "${AGL_APP_REVISION}"
+SRCREV = "70dfe121582cda2c82c794e5af6550b5c1a237c4"
 
 S = "${WORKDIR}/git"
 
index a5fa443..61050bc 100644 (file)
@@ -11,7 +11,7 @@ DEPENDS = "qtquickcontrols2 libqtappfw gstreamer1.0"
 PV = "1.0+git${SRCPV}"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/phone;protocol=https;branch=${AGL_BRANCH}"
-SRCREV  = "${AGL_APP_REVISION}"
+SRCREV  = "bfcc2fa194474a7bc317583072b62c977ae0fc14"
 
 S = "${WORKDIR}/git"
 
index b98d0fd..57b6df8 100644 (file)
@@ -15,7 +15,7 @@ SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/radio;protocol=https;bra
            file://presets-CES.conf \
            file://presets-FOSDEM.conf \
 "
-SRCREV  = "${AGL_APP_REVISION}"
+SRCREV  = "f48bb2aab34273bd5b3cc1f9f9d88afbfb231d6b"
 
 S  = "${WORKDIR}/git"
 
index 4dd1513..84d830c 100644 (file)
@@ -17,7 +17,7 @@ DEPENDS = " \
 PV = "2.0+git${SRCPV}"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/settings;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "${AGL_APP_REVISION}"
+SRCREV = "26dc6a8c8847248450bf902124b7cd867e027274"
 
 S  = "${WORKDIR}/git"
 
index d5c1423..08db5d1 100755 (executable)
@@ -20,7 +20,7 @@ AGL_EXTRA_IMAGE_FSTYPES ?= ""
 
 # important settings imported from poky-agl.conf
 # we do not import 
-DISTRO_FEATURES:append = " systemd smack"
+DISTRO_FEATURES:append = " systemd"
 DISTRO_FEATURES_BACKFILL_CONSIDERED:append = " sysvinit"
 VIRTUAL-RUNTIME_init_manager = "systemd"
 #AGL_FEATURES += "aglcore agldemo"
@@ -29,13 +29,6 @@ VIRTUAL-RUNTIME_init_manager = "systemd"
 # workaround:
 #ERROR: Nothing RPROVIDES 'qtwebengine-qmlplugins' (but /home/dl9pf/AGL/master-newlayout/external/meta-qt5/recipes-qt/qt5/qt5-creator_git.bb RDEPENDS on or otherwise requires it)
 BBMASK += "meta-qt5/recipes-qt/qt5/qt5-creator_git.bb"
-#ERROR: Nothing RPROVIDES 'python' (but /home/dl9pf/AGL/master-newlayout/external/meta-security/recipes-mac/smack/smack-test_1.0.bb RDEPENDS on or otherwise requires it)
-BBMASK += "meta-security/recipes-mac/smack/smack-test_1.0.bb"
-
-# missing in upstream recipes ... aka FIXME upstream
-BBCLASSEXTEND:pn-libzip = "native nativesdk"
-BBCLASSEXTEND:pn-xmlsec1 = "native nativesdk"
-AGL_APP_REVISION = "${AUTOREV}"
 
 EOF