Remove use of AGL_APP_REVISION
[AGL/meta-agl-demo.git] / recipes-demo / homescreen / homescreen_git.bb
1 SUMMARY     = "Home Screen application"
2 DESCRIPTION = "AGL demonstration Home Screen application"
3 HOMEPAGE    = "http://docs.automotivelinux.org"
4 LICENSE     = "Apache-2.0"
5 SECTION     = "apps"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
7
8 DEPENDS = " \
9     qtbase \
10     qtdeclarative \
11     qtquickcontrols2 \
12     libqtappfw \
13     wayland-native \
14     wayland \
15     qtwayland \
16     qtwayland-native \
17     agl-compositor \
18     applaunchd \
19 "
20
21 PV = "1.0+git${SRCPV}"
22
23 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/homescreen;protocol=https;branch=${AGL_BRANCH} \
24            file://homescreen.service \
25 "
26 SRCREV = "c35327b02a28a83536450a664326d183662e89e1"
27
28 S = "${WORKDIR}/git"
29
30 inherit qmake5 systemd pkgconfig
31
32 PATH:prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
33
34 OE_QMAKE_CXXFLAGS:append = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', '' , '-DQT_NO_DEBUG_OUTPUT', d)}"
35
36 do_install:append() {
37     install -d ${D}${systemd_user_unitdir}/agl-session.target.wants
38     install -m0644 ${WORKDIR}/homescreen.service ${D}${systemd_user_unitdir}/homescreen.service
39     ln -s ../homescreen.service ${D}${systemd_user_unitdir}/agl-session.target.wants/homescreen.service
40 }
41
42 FILES:${PN} += " ${systemd_user_unitdir}"
43
44 RDEPENDS:${PN} += " \
45     libqtappfw \
46     applaunchd \
47     qtwayland \
48     qtbase-qmlplugins \
49     qtgraphicaleffects-qmlplugins \
50 "