Remove use of AGL_APP_REVISION
[AGL/meta-agl-demo.git] / recipes-demo / dashboard / dashboard_git.bb
1 SUMMARY     = "Dashboard application"
2 DESCRIPTION = "AGL demonstration Dashboard application"
3 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/dashboard"
4 SECTION     = "apps"
5
6 LICENSE = "Apache-2.0"
7 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
8
9 DEPENDS = " \
10     qttools-native \
11     qtquickcontrols2 \
12 "
13
14 PV = "2.0+git${SRCPV}"
15
16 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/dashboard;protocol=https;branch=${AGL_BRANCH}"
17 SRCREV  = "3fc84a0a674fa532f6aded100cf2beb3d0cf1f83"
18
19 S = "${WORKDIR}/git"
20
21 inherit qmake5 pkgconfig
22
23 FILES:${PN} += "${datadir}/icons/"
24
25 RDEPENDS:${PN} += " \
26     qtwayland \
27     qtbase-qmlplugins \
28     qtgraphicaleffects-qmlplugins \
29     qtquickcontrols2-agl-style \
30 "