ffa1234fec9fd0b5023aff7e31d04ba8bc59a8d6
[AGL/meta-agl-demo.git] / recipes-demo / hvac / hvac_git.bb
1 SUMMARY     = "HVAC application"
2 DESCRIPTION = "AGL demonstration HVAC application"
3 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/hvac"
4 SECTION     = "apps"
5
6 LICENSE = "Apache-2.0"
7 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
8
9 DEPENDS = " \
10     qttools-native \
11     qtbase \
12     qtdeclarative \
13     qtquickcontrols2 \
14     libqtappfw \
15 "
16
17 PV = "2.0+git${SRCPV}"
18
19 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/hvac;protocol=https;branch=${AGL_BRANCH}"
20 SRCREV = "${AGL_APP_REVISION}"
21
22 S = "${WORKDIR}/git"
23
24 inherit qmake5 pkgconfig
25
26 FILES:${PN} += "${datadir}/icons/"
27
28 RDEPENDS:${PN} += " \
29     qtwayland \
30     qtbase-qmlplugins \
31     qtgraphicaleffects-qmlplugins \
32     qtquickcontrols2-agl-style \
33     libqtappfw \
34 "