Remove use of AGL_APP_REVISION
[AGL/meta-agl-demo.git] / recipes-demo / settings / settings_git.bb
1 SUMMARY     = "Settings application"
2 DESCRIPTION = "AGL demonstration Settings application"
3 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/settings"
4 SECTION     = "apps"
5
6 LICENSE = "Apache-2.0"
7 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
8
9 DEPENDS = " \
10     qtbase \
11     qtdeclarative \
12     qtquickcontrols2 \
13     qtvirtualkeyboard \
14     libqtappfw \
15 "
16
17 PV = "2.0+git${SRCPV}"
18
19 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/settings;protocol=https;branch=${AGL_BRANCH}"
20 SRCREV = "26dc6a8c8847248450bf902124b7cd867e027274"
21
22 S  = "${WORKDIR}/git"
23
24 inherit qmake5 pkgconfig
25
26 FILES:${PN} += "${datadir}/icons/"
27
28 RDEPENDS:${PN} += " \
29     qtwayland \
30     qtbase-qmlplugins \
31     qtgraphicaleffects-qmlplugins \
32     qtquickcontrols2-agl-style \
33     libqtappfw \
34 "