04f34da6b97079d9fd9cdd7a949e864298742e13
[AGL/meta-agl-demo.git] / recipes-demo / launcher / launcher_git.bb
1 SUMMARY     = "AGL Launcher Application"
2 DESCRIPTION = "AGL Launcher Application build with recipe method"
3 HOMEPAGE    = "https://git.automotivelinux.org/apps/launcher"
4 SECTION     = "apps"
5 LICENSE     = "Apache-2.0"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
7
8 DEPENDS = "\
9         qtbase \
10         qtdeclarative \
11         qtquickcontrols2 \
12         qtwebsockets \
13         wayland-native \
14         wayland \
15         qtwayland \
16         qtwayland-native \
17         agl-compositor \
18         json-c \
19         applaunchd \
20 "
21
22 PV      = "1.0+git${SRCPV}"
23
24 SRC_URI = " \
25         git://gerrit.automotivelinux.org/gerrit/apps/launcher;protocol=https;branch=${AGL_BRANCH} \
26         file://launcher.service \
27         "
28 SRCREV  = "${AGL_APP_REVISION}"
29
30 S       = "${WORKDIR}/git"
31
32 inherit qmake5 systemd pkgconfig
33
34 PATH:prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
35
36 do_install:append() {
37     install -d ${D}${systemd_user_unitdir}/agl-session.target.wants
38     install -m0644 ${WORKDIR}/launcher.service ${D}${systemd_user_unitdir}/launcher.service
39     ln -s ../launcher.service ${D}${systemd_user_unitdir}/agl-session.target.wants/launcher.service
40 }
41
42 FILES:${PN} += " ${systemd_user_unitdir}"
43
44 RDEPENDS:${PN} += " \
45     applaunchd \
46     homescreen \
47 "