d43ab437627ff13a38393269be1746bfcd7ede49
[AGL/meta-agl-demo.git] / recipes-demo / cluster-receiver / qt-cluster-receiver_git.bb
1 SUMMARY     = "Instrument Cluster receiver application"
2 DESCRIPTION = "AGL demonstration instrument cluster Qt remote display application"
3 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/admin/repos/apps/agl-qt-cluster-demo-receiver"
4 SECTION     = "apps"
5
6 LICENSE     = "Apache-2.0 & MIT"
7 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984 \
8                     file://app/surface.hpp;beginline=5;endline=21;md5=5351c531a191f0e3463aafcd0a6a00a3"
9
10 DEPENDS = " \
11     wayland wayland-native \
12     qtwayland qtwayland-native \
13     qtquickcontrols2 qtwebsockets qtbase qtdeclarative \
14     gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad \
15 "
16
17 PV = "1.0+git${SRCPV}"
18
19 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-qt-cluster-demo-receiver;protocol=https;branch=${AGL_BRANCH} \
20            file://qt-cluster-receiver.service \
21 "
22 SRCREV  = "${AGL_APP_REVISION}"
23
24 S  = "${WORKDIR}/git"
25
26 inherit cmake_qt5 pkgconfig
27
28 do_install:append() {
29     # Only install unit, do not enable it by default
30     install -D -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_user_unitdir}/${BPN}.service
31 }
32
33 FILES:${PN} += " ${systemd_user_unitdir}"
34
35 RDEPENDS:${PN} += " \
36     qtwayland \
37     gstreamer1.0-plugins-base \
38     gstreamer1.0-plugins-good \
39     gstreamer1.0-plugins-bad \
40 "