kernel: most: add mostcore module dependencies 47/8447/1
authorMatt Ranostay <matt.ranostay@konsulko.com>
Tue, 14 Feb 2017 02:08:59 +0000 (02:08 +0000)
committerMatt Ranostay <matt.ranostay@konsulko.com>
Tue, 14 Feb 2017 18:36:59 +0000 (18:36 +0000)
Varies recipes depend on the mostcore module being built
first. This patchset fixes a race condition that causes
invalid module builds.

Issue: SPEC-438
Change-Id: I045e88bc4aa31409937860a377bc43c25a194a2e
Signed-off-by: Matt Ranostay <matt.ranostay@konsulko.com>
recipes-kernel/aim-cdev/aim-cdev.bb
recipes-kernel/aim-network/aim-network.bb
recipes-kernel/aim-sound/aim-sound.bb
recipes-kernel/aim-v4l2/aim-v4l2.bb
recipes-kernel/hdm-dim2/hdm-dim2.bb
recipes-kernel/hdm-i2c/hdm-i2c.bb
recipes-kernel/hdm-usb/hdm-usb.bb

index 09c24ce..e8c101e 100644 (file)
@@ -1,6 +1,7 @@
 DESCRIPTION = "Build character device driver for MOST"
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+DEPENDS = " mostcore"
 
 inherit module
 
index b731f93..7ef192c 100644 (file)
@@ -1,6 +1,7 @@
 DESCRIPTION = "Build networking driver for MOST"
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+DEPENDS = " mostcore"
 
 inherit module
 
index ae8d7d8..cb2b983 100644 (file)
@@ -1,6 +1,7 @@
 DESCRIPTION = "Build ALSA driver for MOST"
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+DEPENDS = " mostcore"
 
 inherit module
 
index 41dbf6d..5233eed 100644 (file)
@@ -1,6 +1,7 @@
 DESCRIPTION = "Build V4L2 driver for MOST"
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+DEPENDS = " mostcore"
 
 inherit module
 
index 6e156f1..a917929 100644 (file)
@@ -1,6 +1,7 @@
 DESCRIPTION = "Build DIM2 adapter driver for MOST"
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+DEPENDS = " mostcore"
 
 inherit module
 
index e1e93ee..90216ec 100644 (file)
@@ -1,6 +1,7 @@
 DESCRIPTION = "Build I2C adapter driver for MOST"
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+DEPENDS = " mostcore"
 
 inherit module
 
index 4c1ef8a..df45e37 100644 (file)
@@ -1,6 +1,7 @@
 DESCRIPTION = "Build USB adapter driver for MOST"
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+DEPENDS = " mostcore"
 
 inherit module