kernel: most: add mostcore module dependencies
[AGL/meta-agl-demo.git] / recipes-kernel / aim-v4l2 / aim-v4l2.bb
1 DESCRIPTION = "Build V4L2 driver for MOST"
2 LICENSE = "GPLv2"
3 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
4 DEPENDS = " mostcore"
5
6 inherit module
7
8 PV = "0.1"
9
10 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/most;protocol=https"
11
12 S = "${WORKDIR}/git/driver/${PN}"
13 SRCREV = "${AUTOREV}"
14
15 # The inherit of module.bbclass will automatically name module packages with
16 # "kernel-module-" prefix as required by the oe-core build environment.
17
18 do_install_append () {
19     # modprobe automatically at boot
20     if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
21         install -d ${D}${sysconfdir}/modules-load.d
22         echo "aim_v4l2" > ${D}${sysconfdir}/modules-load.d/aim_v4l2.conf
23     fi
24 }