kernel: most: add mostcore module dependencies
[AGL/meta-agl-demo.git] / recipes-kernel / aim-network / aim-network.bb
1 DESCRIPTION = "Build networking driver for MOST"
2 LICENSE = "GPLv2"
3 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
4 DEPENDS = " mostcore"
5
6 inherit module
7
8 PV = "0.1"
9
10 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/most;protocol=https"
11 SRC_URI_append_porter = " file://0001-aim-network-backport-patch-for-3.10.31-ltsi.patch"
12
13 S = "${WORKDIR}/git/driver/${PN}"
14 SRCREV = "${AUTOREV}"
15
16 # The inherit of module.bbclass will automatically name module packages with
17 # "kernel-module-" prefix as required by the oe-core build environment.
18
19 do_install_append () {
20     # modprobe automatically at boot
21     if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
22         install -d ${D}${sysconfdir}/modules-load.d
23         echo "aim_network" > ${D}${sysconfdir}/modules-load.d/aim_network.conf
24     fi
25 }