4c1ef8a6d6a72dcde43fc959ed7cc03223a7944c
[AGL/meta-agl-demo.git] / recipes-kernel / hdm-usb / hdm-usb.bb
1 DESCRIPTION = "Build USB adapter driver for MOST"
2 LICENSE = "GPLv2"
3 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
4
5 inherit module
6
7 PV = "0.1"
8
9 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/most;protocol=https"
10
11 S = "${WORKDIR}/git/driver/${PN}"
12 SRCREV = "${AUTOREV}"
13
14 # The inherit of module.bbclass will automatically name module packages with
15 # "kernel-module-" prefix as required by the oe-core build environment.
16
17 do_install_append () {
18     # modprobe automatically at boot
19     if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
20         install -d ${D}${sysconfdir}/modules-load.d
21         echo "hdm_usb" > ${D}${sysconfdir}/modules-load.d/hdm_usb.conf
22     fi
23 }