Add recipe for ebizzy package for QA 77/5477/2
authorStephane Desneux <stephane.desneux@iot.bzh>
Thu, 31 Mar 2016 16:13:20 +0000 (18:13 +0200)
committerGerrit Code Review <gerrit@172.30.200.200>
Mon, 4 Apr 2016 22:04:42 +0000 (22:04 +0000)
Change-Id: Iafcdfc58636eb5b42b6251f46baac96a55e28ed7
Signed-off-by: Stephane Desneux <stephane.desneux@iot.bzh>
meta-ivi-common/recipes-test/ebizzy/ebizzy_0.3.bb [new file with mode: 0644]

diff --git a/meta-ivi-common/recipes-test/ebizzy/ebizzy_0.3.bb b/meta-ivi-common/recipes-test/ebizzy/ebizzy_0.3.bb
new file mode 100644 (file)
index 0000000..1996041
--- /dev/null
@@ -0,0 +1,18 @@
+DESCRIPTION = "Benchmark tool that generates a workload resembling common web application server workloads"
+HOMEPAGE = "http://ebizzy.sourceforge.net/"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=eb723b61539feef013de476e68b5c50a"
+
+SRC_URI = "http://downloads.sourceforge.net/project/ebizzy/ebizzy/${PV}/ebizzy-${PV}.tar.gz"
+SRC_URI[md5sum] = "af038bc506066bb3d28db08aba62bc38"
+SRC_URI[sha256sum] = "77286029d6348f3d9b3f04eae1feadb5ad1ad07b9f688f4d9f002960862467f2"
+
+do_compile () {
+       ${CC} -Wall -Wshadow -lpthread -o ebizzy ebizzy.c
+}
+
+do_install () {
+       install -d ${D}${bindir}
+       install -m 0755 ebizzy ${D}${bindir}
+}
+