Add new recipe for Himeno Benchmark 59/5459/1
authorYannick Gicquel <yannick.gicquel@iot.bzh>
Thu, 31 Mar 2016 12:18:33 +0000 (14:18 +0200)
committerYannick Gicquel <yannick.gicquel@iot.bzh>
Thu, 31 Mar 2016 12:18:33 +0000 (14:18 +0200)
Please refer to http://accc.riken.jp/en/supercom/himenobmt/
for more details on this benchmark.

Change-Id: Ia1261940035549086d0c93d61fd5a5d75e83fbcb
Signed-off-by: Yannick Gicquel <yannick.gicquel@iot.bzh>
meta-ivi-common/recipes-test/himeno/himeno_2.0.bb [new file with mode: 0644]

diff --git a/meta-ivi-common/recipes-test/himeno/himeno_2.0.bb b/meta-ivi-common/recipes-test/himeno/himeno_2.0.bb
new file mode 100644 (file)
index 0000000..56177b9
--- /dev/null
@@ -0,0 +1,24 @@
+DESCRIPTION = "Himeno Benchmark"
+LICENSE = "LGPL-2.0"
+URL = "http://accc.riken.jp/en/supercom/himenobmt/"
+
+SRC_URI = "http://accc.riken.jp/en/wp-content/uploads/sites/2/2015/07/himenobmt.c.zip"
+SRC_URI[md5sum] = "8d8e837dfc3e00a3b322eb4ae3edd551"
+SRC_URI[sha256sum] = "8780bfbdacb0d4dcab2931e65cadd69411731e3f2afcc1231d0743a036298077"
+
+LIC_FILES_CHKSUM = "file://himenoBMT.c;md5=8e8771ddc01c6d1a795e088e2d6dee78"
+
+# Upstream ZIP file contains an LZH archive, thus a 2 steps "unpack" is required.
+# The LZH archive is unpacked after native tools dependency resolution,
+# thus. after "configure" task in our case:
+
+DEPENDS = "p7zip-native"
+
+do_configure_append() {
+    7z x -y -o${S} ${WORKDIR}/himenobmt.c.lzh
+}
+
+do_install () {
+    install -d ${D}${bindir}
+    install -m 0755 bmt ${D}${bindir}
+}