p7zip: add native build support 57/5457/1
authorYannick Gicquel <yannick.gicquel@iot.bzh>
Thu, 31 Mar 2016 12:09:20 +0000 (14:09 +0200)
committerYannick Gicquel <yannick.gicquel@iot.bzh>
Thu, 31 Mar 2016 12:10:03 +0000 (14:10 +0200)
This is a host dependency to himeno benchmark recipe

Change-Id: Ibf0dcaa866d94e533fc43d5a84ca38fa3a08ea07
Signed-off-by: Yannick Gicquel <yannick.gicquel@iot.bzh>
meta-ivi-common/recipes-extended/p7zip/p7zip_9.20.1.bbappend [new file with mode: 0644]

diff --git a/meta-ivi-common/recipes-extended/p7zip/p7zip_9.20.1.bbappend b/meta-ivi-common/recipes-extended/p7zip/p7zip_9.20.1.bbappend
new file mode 100644 (file)
index 0000000..98a51a1
--- /dev/null
@@ -0,0 +1,22 @@
+# This bbappend is to implement native package built
+#
+# native support has been submitted upstream, and may land in meta-openembedded:
+#  http://lists.openembedded.org/pipermail/openembedded-devel/2016-March/106755.html
+
+# all3: to build bin/7za, bin/7z (with its plugins), bin/7zr and bin/7zCon.sfx
+EXTRA_OEMAKE_class-native = "all3"
+
+do_install_class-native() {
+    install -d ${D}${bindir}
+    install -d ${D}${bindir}/Codecs
+    install -m 0755 ${S}/bin/7* ${D}${bindir}
+    install -m 0755 ${S}/bin/Codecs/* ${D}${bindir}/Codecs
+
+    # Create a shell script wrapper to execute next to 7z.so
+    mv ${D}${bindir}/7z ${D}${bindir}/7z.bin
+    echo "#! /bin/sh" > ${D}${bindir}/7z
+    echo "exec ${D}${bindir}/7z.bin \"\$@\"" >> ${D}${bindir}/7z
+    chmod 0755 ${D}${bindir}/7z
+}
+
+BBCLASSEXTEND += "native"