Add new recipe for Himeno Benchmark
[AGL/meta-agl.git] / meta-ivi-common / recipes-test / himeno / himeno_2.0.bb
1 DESCRIPTION = "Himeno Benchmark"
2 LICENSE = "LGPL-2.0"
3 URL = "http://accc.riken.jp/en/supercom/himenobmt/"
4
5 SRC_URI = "http://accc.riken.jp/en/wp-content/uploads/sites/2/2015/07/himenobmt.c.zip"
6 SRC_URI[md5sum] = "8d8e837dfc3e00a3b322eb4ae3edd551"
7 SRC_URI[sha256sum] = "8780bfbdacb0d4dcab2931e65cadd69411731e3f2afcc1231d0743a036298077"
8
9 LIC_FILES_CHKSUM = "file://himenoBMT.c;md5=8e8771ddc01c6d1a795e088e2d6dee78"
10
11 # Upstream ZIP file contains an LZH archive, thus a 2 steps "unpack" is required.
12 # The LZH archive is unpacked after native tools dependency resolution,
13 # thus. after "configure" task in our case:
14
15 DEPENDS = "p7zip-native"
16
17 do_configure_append() {
18     7z x -y -o${S} ${WORKDIR}/himenobmt.c.lzh
19 }
20
21 do_install () {
22     install -d ${D}${bindir}
23     install -m 0755 bmt ${D}${bindir}
24 }