Add the cloudproxy service in meta-agl-demo 04/25004/5 9.99.2 jellyfish/9.99.2 jellyfish_9.99.2
authorLeonid Lazarev <leonid.lazarev@orioninc.com>
Mon, 13 Jul 2020 14:51:02 +0000 (17:51 +0300)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Fri, 24 Jul 2020 15:51:08 +0000 (15:51 +0000)
The recipes for cloudproxy service has been added in ivi-service packagegroup
The new feature cloudproxy has been added to agl-demo

Bug-AGL: SPEC-3496
Change-Id: I9d9a2efd5d686b25b593ddc18a9147aa27d5054c
Signed-off-by: Leonid Lazarev <leonid.lazarev@orioninc.com>
recipes-apis/agl-service-cloudproxy/agl-service-cloudproxy_git.bb [new file with mode: 0644]
recipes-platform/packagegroups/packagegroup-agl-ivi-services.bb
templates/feature/agl-cloudproxy/50_local.conf.inc [new file with mode: 0644]

diff --git a/recipes-apis/agl-service-cloudproxy/agl-service-cloudproxy_git.bb b/recipes-apis/agl-service-cloudproxy/agl-service-cloudproxy_git.bb
new file mode 100644 (file)
index 0000000..dcfb384
--- /dev/null
@@ -0,0 +1,24 @@
+SUMMARY     = "AGL cloud proxy service"
+DESCRIPTION = "AGL cloud proxy service build with recipe method"
+HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/apps/agl-service-cloudproxy"
+SECTION     = "apps"
+LICENSE     = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=133bb7bd14f18c4f134e819619b3f09a"
+
+inherit cmake aglwgt pkgconfig
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-cloudproxy;protocol=https"
+
+SRCREV = "0cecffd4565b52bd8d200f6bc9f4144f244a6515"
+
+PV      = "1.0+git${SRCPV}"
+S       = "${WORKDIR}/git/"
+
+DEPENDS = "azure-iot-sdk-c glib-2.0"
+
+RDEPENDS_${PN} += "azure-iot-sdk-c azure-c-shared-utility"
+
+#azure include files
+CXXFLAGS_prepend += "-I${STAGING_INCDIR}/azureiot"
+
+BBCLASSEXTEND = "native nativesdk"
index e9131db..9deeda5 100644 (file)
@@ -27,4 +27,5 @@ RDEPENDS_${PN} += "\
     agl-service-unicens-controller \
     agl-service-weather \
     ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'agl-service-taskmanager', '', d)} \
+    ${@bb.utils.contains('AGL_CLOUDPROXY_WANTED','1', 'agl-service-cloudproxy', '', d)} \
     "
diff --git a/templates/feature/agl-cloudproxy/50_local.conf.inc b/templates/feature/agl-cloudproxy/50_local.conf.inc
new file mode 100644 (file)
index 0000000..93b0cb4
--- /dev/null
@@ -0,0 +1,2 @@
+# Set cloud proxy flag
+AGL_CLOUDPROXY_WANTED = "1"
\ No newline at end of file