Add the cloudproxy service in meta-agl-demo
[AGL/meta-agl-demo.git] / recipes-apis / agl-service-cloudproxy / agl-service-cloudproxy_git.bb
1 SUMMARY     = "AGL cloud proxy service"
2 DESCRIPTION = "AGL cloud proxy service build with recipe method"
3 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/apps/agl-service-cloudproxy"
4 SECTION     = "apps"
5 LICENSE     = "Apache-2.0"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=133bb7bd14f18c4f134e819619b3f09a"
7
8 inherit cmake aglwgt pkgconfig
9
10 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-cloudproxy;protocol=https"
11
12 SRCREV = "0cecffd4565b52bd8d200f6bc9f4144f244a6515"
13
14 PV      = "1.0+git${SRCPV}"
15 S       = "${WORKDIR}/git/"
16
17 DEPENDS = "azure-iot-sdk-c glib-2.0"
18
19 RDEPENDS_${PN} += "azure-iot-sdk-c azure-c-shared-utility"
20
21 #azure include files
22 CXXFLAGS_prepend += "-I${STAGING_INCDIR}/azureiot"
23
24 BBCLASSEXTEND = "native nativesdk"