Add aws-iot-device-embedded-c support to crosssdk 69/24969/5
authorAndrey Shamanin <andrei.shamanin@orioninc.com>
Tue, 7 Jul 2020 11:31:49 +0000 (14:31 +0300)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Thu, 23 Jul 2020 08:25:28 +0000 (08:25 +0000)
AWS SDK is included to AGL cross SDK, it allows users to use AWS SDK
during appropriate (working with cloud) AGL application development.

v2: resubmit

Library mbedTLS has been added to AGL SDK, because it is required for AWS SDK.

Bug-AGL: SPEC-3480

Signed-off-by: Andrey Shamanin <andrei.shamanin@orioninc.com>
Change-Id: I015ecad01970bebad8f25b8c5024cbe74c7fd78c
Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
recipes-platform/images/agl-demo-platform-crosssdk.bb

index 35883ae..641befa 100644 (file)
@@ -40,6 +40,16 @@ TOOLCHAIN_TARGET_TASK += "libstdc++-staticdev"
 # memory issue.
 TOOLCHAIN_TARGET_TASK += "gcc-sanitizers"
 
-# Add azure-iot-sdk-c to support building agl-service-cloudproxy and
-# other users of Azure sdk.
+# Add azure-iot-sdk-c to support building agl-service-cloudproxy
+# and other users of Azure sdk.
 TOOLCHAIN_TARGET_TASK += "azure-iot-sdk-c umock-c"
+
+# Add mbedTLS to support building aws-iot-device-sdk-embedded-c
+TOOLCHAIN_TARGET_TASK += "mbedtls"
+
+# Add aws-iot-device-embedded-c sdk to support building agl-service-cloudproxy
+# and other users of AWS sdk.
+# These packages are required to add static library and headers:
+TOOLCHAIN_TARGET_TASK += "aws-iot-device-sdk-embedded-c-staticdev"
+TOOLCHAIN_TARGET_TASK += "aws-iot-device-sdk-embedded-c-dev"
+