Rework IVI image packagegroups 36/29636/2
authorScott Murray <scott.murray@konsulko.com>
Tue, 20 Feb 2024 15:56:41 +0000 (10:56 -0500)
committerScott Murray <scott.murray@konsulko.com>
Mon, 18 Mar 2024 21:23:02 +0000 (21:23 +0000)
The all-in-one packagegroup-agl-image-ivi makes it difficult to
use the dependencies it pulls into images in a piecemeal fashion.
It has been removed and instead its dependencies are included in
the base IVI image defintion.  As well, the IVI services
packagegroup has been split to have packagegroups for applaunchd
versus platform-dependent services (audio, HVAC, etc.).
These will enable doing using conditional logic in the IVI image
defintion that will be more visible and not break binary packaging.

Bug-AGL: SPEC-5082

Change-Id: Ia4e95656e2fbc6d8ed6ba98c19b33f6fe6ca5971
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29698
ci-image-boot-test: Jenkins Job builder account
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
ci-image-build: Jenkins Job builder account
Tested-by: Jenkins Job builder account
(cherry picked from commit e756238f831c825a02c0d27a01d85afdbfca4004)
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29636

recipes-platform/images/agl-image-ivi.bb
recipes-platform/packagegroups/packagegroup-agl-demo-platform-flutter.bb
recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
recipes-platform/packagegroups/packagegroup-agl-image-ivi.bb [deleted file]
recipes-platform/packagegroups/packagegroup-agl-ivi-services.bb

index 4fa9506..c0b6e4f 100644 (file)
@@ -7,9 +7,15 @@ LICENSE = "MIT"
 require recipes-platform/images/agl-image-compositor.bb
 
 IMAGE_INSTALL += " \
-    packagegroup-agl-image-ivi \
-    packagegroup-agl-ivi-services \
     can-utils \
+    packagegroup-agl-ivi-connectivity \
+    packagegroup-agl-ivi-graphics \
+    packagegroup-agl-ivi-multimedia \
+    packagegroup-agl-ivi-multimedia-hardware \
+    packagegroup-agl-ivi-navigation \
+    packagegroup-agl-ivi-identity \
+    packagegroup-agl-ivi-services-applaunchd \
+    packagegroup-agl-ivi-services-platform \
     iproute2 \
     "
 
index e01c315..015cde9 100644 (file)
@@ -11,7 +11,6 @@ PACKAGES = "\
     "
 
 RDEPENDS:${PN} += "\
-    packagegroup-agl-image-ivi \
     packagegroup-agl-kuksa-val-databroker \
     packagegroup-agl-demo \
     "
index cf8268d..f03229d 100644 (file)
@@ -11,7 +11,6 @@ PACKAGES = "\
     "
 
 RDEPENDS:${PN} += "\
-    packagegroup-agl-image-ivi \
     packagegroup-agl-kuksa-val-databroker \
     packagegroup-agl-demo \
     "
diff --git a/recipes-platform/packagegroups/packagegroup-agl-image-ivi.bb b/recipes-platform/packagegroups/packagegroup-agl-image-ivi.bb
deleted file mode 100644 (file)
index c3d6f57..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
-SUMMARY = "The middlewares for AGL IVI profile"
-DESCRIPTION = "The set of packages required for AGL Distribution"
-LICENSE = "MIT"
-
-inherit packagegroup
-
-PACKAGES = "\
-    packagegroup-agl-image-ivi \
-    "
-
-ALLOW_EMPTY:${PN} = "1"
-
-RDEPENDS:${PN} += "\
-    packagegroup-agl-image-minimal \
-"
-
-RDEPENDS:${PN} += "\
-    packagegroup-agl-ivi-connectivity \
-    packagegroup-agl-ivi-graphics \
-    packagegroup-agl-ivi-multimedia \
-    packagegroup-agl-ivi-multimedia-hardware \
-    packagegroup-agl-ivi-navigation \
-    packagegroup-agl-ivi-identity \
-    packagegroup-agl-ivi-services \
-    "
-
index e4a4a9d..c3a53d5 100644 (file)
@@ -5,12 +5,22 @@ inherit packagegroup
 
 PACKAGES = "\
     packagegroup-agl-ivi-services \
-    "
+    packagegroup-agl-ivi-services-platform \
+    packagegroup-agl-ivi-services-applaunchd \
+"
 
-RDEPENDS:${PN} += "\
+RDEPENDS:${PN}-applaunchd += " \
     applaunchd \
     applaunchd-template-agl-app \
+"
+
+RDEPENDS:${PN}-platform += " \
     agl-service-hvac \
     agl-service-audiomixer \
     agl-service-radio \
-    "
+"
+
+RDEPENDS:${PN} += " \
+    packagegroup-agl-ivi-services-applaunchd \
+    packagegroup-agl-ivi-services-platform \
+"