9c93b32c2a46cd46cc8333b8ca171eb4a5ea3551
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-agl-demo-platform-html5.bb
1 SUMMARY = "The software for DEMO platform of AGL IVI profile"
2 DESCRIPTION = "A set of packages belong to AGL Demo Platform"
3
4 LICENSE = "MIT"
5
6 inherit packagegroup
7
8 PROVIDES = "${PACKAGES}"
9 PACKAGES = "\
10     packagegroup-agl-demo-platform-html5 \
11     "
12
13 RDEPENDS:${PN} += "\
14     packagegroup-agl-image-ivi \
15     packagegroup-agl-demo \
16     "
17
18 # TODO(jdapena): replace this with HTML5 apps.
19 AGL_APPS = " \
20     html5-dashboard \
21     html5-launcher \
22     html5-homescreen \
23     html5-hvac \
24     html5-mediaplayer \
25     html5-mixer \
26     html5-settings \
27     html5-aquarium \
28     html5-youtube \
29     html5-jitsi \
30     html5-examples \
31     "
32
33 RDEPENDS:${PN}:append = " \
34     wam \
35     weston-ini-conf-landscape-no-activate \
36     ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'unzip' , '', d)} \
37     qtquickcontrols2-agl \
38     qtquickcontrols2-agl-style \
39     ${AGL_APPS} \
40     "
41
42 # nss-agl-driver-db is required to connect to kuksa
43 RDEPENDS:${PN}:append = " nss-agl-driver-db "
44