Migrate poiapp and libnaviapi-agl to AGL Gerrit 66/22366/1
authorScott Murray <scott.murray@konsulko.com>
Mon, 9 Sep 2019 23:54:08 +0000 (19:54 -0400)
committerScott Murray <scott.murray@konsulko.com>
Mon, 9 Sep 2019 23:56:34 +0000 (19:56 -0400)
Update the poiapp and libnaviapi-agl recipes to point at AGL Gerrit for
their source repositories.  Additionally, the libnaviapi-agl recipe has
been moved to recipes-demo/navigation since being beside its users seems
to be a more logical location, and a few lines have been reordered in
the poiapp recipe to better match the OpenEmbedded style guide.

Bug-AGL: SPEC-2787

Change-Id: I41334b47b4970adb51fc943368dba7e07bbf113d
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
recipes-demo-hmi/navigation/libnaviapi-agl_git.bb [moved from recipes-demo-hmi/libnaviapi-agl/libnaviapi-agl_git.bb with 76% similarity, mode: 0644]
recipes-demo-hmi/navigation/poiapp_git.bb

old mode 100755 (executable)
new mode 100644 (file)
similarity index 76%
rename from recipes-demo-hmi/libnaviapi-agl/libnaviapi-agl_git.bb
rename to recipes-demo-hmi/navigation/libnaviapi-agl_git.bb
index e4dc844..87087e1
@@ -10,8 +10,8 @@ DEPENDS = "af-binder json-c libdbus-c++ af-main-native"
 
 inherit cmake
 
-SRC_URI = "git://github.com/AGLExport/agl-service-navigation;protocol=git;branch=master"
-SRCREV  = "1f1ffc92fcc882aa5e885badbc91a3384f5d77b1"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-navigation;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
 S = "${WORKDIR}/git"
 
 # FIXME: Remove once CMake+ninja issues are resolved
index 9c9292b..87263e1 100644 (file)
@@ -6,20 +6,15 @@ SECTION     = "apps"
 LICENSE          = "GPLv2"
 LIC_FILES_CHKSUM = "file://COPYING;md5=947b2d60ca3872e172034438e9801200"
 
-inherit cmake_qt5 pkgconfig
-inherit aglwgt
-
-DEPENDS += " qtbase json-c libnaviapi-agl \
-             af-binder qlibwindowmanager libhomescreen \
+DEPENDS += "qtbase json-c libnaviapi-agl \
+            qlibwindowmanager libhomescreen \
            "
 
-RDEPENDS_${PN} =  " qtbase \
-                  "
-
-SRCREV = "c2691cb265d9198542482a860f1df378e8c2708b"
-SRC_URI = "git://github.com/AGLExport/genivi-navi-yelp-client.git;branch=agl \
-           file://0001-add-display-permission.patch \
-          "
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/poi-yelp;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
 
 S = "${WORKDIR}/git"
 
+inherit cmake_qt5 pkgconfig aglwgt
+
+RDEPENDS_${PN} =  "qtbase"