Migrate poiapp and libnaviapi-agl to AGL Gerrit
[AGL/meta-agl-demo.git] / recipes-demo-hmi / navigation / poiapp_git.bb
1 SUMMARY     = "AGL Reference POI application."
2 DESCRIPTION = "This application provides the function of destination search to AGL.  It uses the API provided by AGL Reference Navigation.  This application uses yelp WebAPI."
3 HOMEPAGE    = "https://github.com/AGLExport/genivi-navi-yelp-client"
4 SECTION     = "apps"
5
6 LICENSE          = "GPLv2"
7 LIC_FILES_CHKSUM = "file://COPYING;md5=947b2d60ca3872e172034438e9801200"
8
9 DEPENDS += "qtbase json-c libnaviapi-agl \
10             qlibwindowmanager libhomescreen \
11            "
12
13 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/poi-yelp;protocol=https;branch=${AGL_BRANCH}"
14 SRCREV = "${AGL_APP_REVISION}"
15
16 S = "${WORKDIR}/git"
17
18 inherit cmake_qt5 pkgconfig aglwgt
19
20 RDEPENDS_${PN} =  "qtbase"