9c9292b08f1aaef42e44f2473c886082eb804407
[AGL/meta-agl-demo.git] / recipes-demo-hmi / navigation / poiapp_git.bb
1 SUMMARY     = "AGL Reference POI application."
2 DESCRIPTION = "This application provides the function of destination search to AGL.  It uses the API provided by AGL Reference Navigation.  This application uses yelp WebAPI."
3 HOMEPAGE    = "https://github.com/AGLExport/genivi-navi-yelp-client"
4 SECTION     = "apps"
5
6 LICENSE          = "GPLv2"
7 LIC_FILES_CHKSUM = "file://COPYING;md5=947b2d60ca3872e172034438e9801200"
8
9 inherit cmake_qt5 pkgconfig
10 inherit aglwgt
11
12 DEPENDS += " qtbase json-c libnaviapi-agl \
13              af-binder qlibwindowmanager libhomescreen \
14            "
15
16 RDEPENDS_${PN} =  " qtbase \
17                   "
18
19 SRCREV = "c2691cb265d9198542482a860f1df378e8c2708b"
20 SRC_URI = "git://github.com/AGLExport/genivi-navi-yelp-client.git;branch=agl \
21            file://0001-add-display-permission.patch \
22           "
23
24 S = "${WORKDIR}/git"
25