agl-demo-platform-crosssdk: add nlohmann-json 94/22694/1
authorScott Murray <scott.murray@konsulko.com>
Wed, 16 Oct 2019 22:32:55 +0000 (18:32 -0400)
committerScott Murray <scott.murray@konsulko.com>
Wed, 16 Oct 2019 22:32:55 +0000 (18:32 -0400)
Add nlohmann-json to target toolchain to support building the speech
services.  This is required until either the agl-speech-framework
feature is added as a dependency of agl-demo, or the speech services
are migrated into the core profile.

Bug-AGL: SPEC-2856, SPEC-2857

Change-Id: I67fe96a73f5cccc8c2dbf2642041f2b64802c512
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
recipes-platform/images/agl-demo-platform-crosssdk.bb

index 088b4cc..7a9b728 100755 (executable)
@@ -63,3 +63,9 @@ TOOLCHAIN_HOST_TASK_append = " nativesdk-perl-modules "
 # meeting to discuss the path forward (separate versus superset SDKs), this
 # should be reviewed after that.
 TOOLCHAIN_TARGET_TASK += "mosquitto-dev"
+
+# Add nlohmann-json to support building the speech services.
+# Required until either the agl-speech-framework feature is added as a
+# dependency of agl-demo, or the speech services are migrated into the
+# core profile.
+TOOLCHAIN_TARGET_TASK += "nlohmann-json-dev"