Refactor packagegroup to enable sllin on h3 48/22548/5
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>
Tue, 1 Oct 2019 09:56:02 +0000 (11:56 +0200)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Wed, 9 Oct 2019 13:29:05 +0000 (13:29 +0000)
Remove the restriction to only add sllin on m3 as we're moving
to the h3 in the demo.

v2: make the settings adjustable in local.conf and remove comment.

Bug-AGL: SPEC-2826

Change-Id: I09ea14934e3714daba6e94c81902453872ce1aa9
Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb

index 8a7b549..d0de2bf 100644 (file)
@@ -20,23 +20,30 @@ RDEPENDS_${PN} += "\
     packagegroup-agl-demo \
     "
 
-MOST_DRIVERS = " \
+# MOST out-of-tree kernel drivers
+#################################
+MOST_DRIVERS ??= " \
     most \
     "
-MOST_DRIVERS_append_m3ulcb = " sllin"
+# These boards use different kernels - needs to be checked
+MOST_DRIVERS_dra7xx-evm ?= ""
+MOST_DRIVERS_dragonboard-410c ?= ""
 
-# HVAC dependencies depend on drivers above
-MOST_HVAC = " "
-MOST_HVAC_append = " \
-    ${MOST_DRIVERS} \
+
+# HVAC dependencies
+###################
+LIN_DRIVERS ??= " sllin"
+# These boards use different kernels - needs to be checked
+LIN_DRIVERS_dra7xx-evm ?= ""
+LIN_DRIVERS_dragonboard-410c ?= ""
+
+# UNICENS service
+UNICENS ?= " \
     unicens-config \
     agl-service-unicens \
     agl-service-unicens-controller \
     "
 
-# @Chris: This needs to be checked!
-MOST_HVAC_dra7xx-evm = ""
-MOST_HVAC_dragonboard-410c = ""
 
 AGL_APPS = " \
     dashboard \
@@ -84,7 +91,9 @@ RDEPENDS_${PN}_append = " \
     qtquickcontrols2-agl \
     qtquickcontrols2-agl-style \
     linux-firmware-ralink \
-    ${MOST_HVAC} \
+    ${UNICENS} \
+    ${MOST_DRIVERS} \
+    ${LIN_DRIVERS} \
     ${AGL_APPS} \
     ${AGL_APIS} \
     ${QTAGLEXTRAS} \