Refactor packagegroup to enable sllin on h3
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-agl-demo-platform.bb
1 SUMMARY = "The software for DEMO platform of AGL IVI profile"
2 DESCRIPTION = "A set of packages belong to AGL Demo Platform"
3
4 LICENSE = "MIT"
5
6 inherit packagegroup
7
8 PACKAGES = "\
9     packagegroup-agl-demo-platform \
10     "
11
12 ALLOW_EMPTY_${PN} = "1"
13
14 RDEPENDS_${PN} += "\
15     packagegroup-agl-image-ivi \
16     "
17
18 RDEPENDS_${PN} += "\
19     packagegroup-agl-profile-graphical-qt5 \
20     packagegroup-agl-demo \
21     "
22
23 # MOST out-of-tree kernel drivers
24 #################################
25 MOST_DRIVERS ??= " \
26     most \
27     "
28 # These boards use different kernels - needs to be checked
29 MOST_DRIVERS_dra7xx-evm ?= ""
30 MOST_DRIVERS_dragonboard-410c ?= ""
31
32
33 # HVAC dependencies
34 ###################
35 LIN_DRIVERS ??= " sllin"
36 # These boards use different kernels - needs to be checked
37 LIN_DRIVERS_dra7xx-evm ?= ""
38 LIN_DRIVERS_dragonboard-410c ?= ""
39
40 # UNICENS service
41 UNICENS ?= " \
42     unicens-config \
43     agl-service-unicens \
44     agl-service-unicens-controller \
45     "
46
47
48 AGL_APPS = " \
49     dashboard \
50     hvac \
51     mediaplayer \
52     virtual/navigation \
53     phone \
54     poiapp \
55     radio \
56     settings \
57     messaging \
58     ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'taskmanager' , '', d)} \
59     high-level-viwi-service \
60     agl-service-signal-composer \
61     low-can-demo \
62     virtual/mixer \
63     "
64
65 AGL_APIS = " \
66     libnaviapi-agl \
67     "
68
69 QTAGLEXTRAS = "${@bb.utils.contains("DISTRO_FEATURES", "agl-hmi-framework", " qtaglextras", "",d)}"
70
71 # Cluster demo support.
72 # ATM mapviewer is required for navigation map viewing when doing cluster
73 # demos with the older navigation application.
74 MAPVIEWER = "${@bb.utils.contains("PREFERRED_PROVIDER_virtual/navigation", "navigation", "mapviewer", "",d)}"
75 CLUSTER_SUPPORT = "${@bb.utils.contains("DISTRO_FEATURES", "agl-cluster-demo-support", "${MAPVIEWER} cluster-demo-network-config", "",d)}"
76
77 # Preload poi API key for demo if requested, and potentially maps for older
78 # navigation application if it is configured.
79 DEMO_MAPS_LOCALE ?= "uk"
80 DEMO_PRELOAD_MAPS = "${@bb.utils.contains("PREFERRED_PROVIDER_virtual/navigation", "navigation", " navigation-maps-${DEMO_MAPS_LOCALE}", "",d)}"
81 DEMO_PRELOAD = "${@bb.utils.contains("DISTRO_FEATURES", "agl-demo-preload", " ${DEMO_PRELOAD_MAPS} poiapp-api-key", "",d)}"
82
83 # Hook for demo platform configuration
84 # ATM, only used to disable btwilink module on M3ULCB + Kingfisher by default,
85 # setting DEMO_ENABLE_BTWILINK to "true" in local.conf / site.conf re-enables.
86 DEMO_ENABLE_BTWILINK ?= ""
87 DEMO_PLATFORM_CONF = ""
88 DEMO_PLATFORM_CONF_append_m3ulcb = "${@bb.utils.contains("DEMO_ENABLE_BTWILINK", "true", "", " btwilink-disable-conf", d)}"
89
90 RDEPENDS_${PN}_append = " \
91     qtquickcontrols2-agl \
92     qtquickcontrols2-agl-style \
93     linux-firmware-ralink \
94     ${UNICENS} \
95     ${MOST_DRIVERS} \
96     ${LIN_DRIVERS} \
97     ${AGL_APPS} \
98     ${AGL_APIS} \
99     ${QTAGLEXTRAS} \
100     ${CLUSTER_SUPPORT} \
101     ${DEMO_PRELOAD} \
102     ${DEMO_PLATFORM_CONF} \
103     "