agl-demo-platform-crosssdk: add nlohmann-json
[AGL/meta-agl-demo.git] / recipes-platform / images / agl-demo-platform-crosssdk.bb
1 SUMMARY = "Cross SDK of Full AGL Distribution for IVI profile"
2
3 DESCRIPTION = "SDK image for full AGL Distribution for IVI profile. \
4 It includes the full meta-toolchain, plus developement headers and libraries \
5 to form a standalone cross SDK."
6
7 require agl-demo-platform.bb
8
9 LICENSE = "MIT"
10
11 IMAGE_FEATURES_append = " dev-pkgs"
12 IMAGE_INSTALL_append = " kernel-dev kernel-devsrc"
13
14 inherit populate_sdk populate_sdk_qt5
15
16 # Task do_populate_sdk and do_rootfs can't be exec simultaneously.
17 # Both exec "createrepo" on the same directory, and so one of them
18 # can failed (randomly).
19 addtask do_populate_sdk after do_rootfs
20
21 # native tools to support Chromium build inside SDK (SPEC-942)
22 TOOLCHAIN_HOST_TASK += " \
23     nativesdk-gn \
24     nativesdk-ninja \
25     nativesdk-gperf \
26     nativesdk-zlib \
27     nativesdk-xz \
28     nativesdk-nspr-dev \
29     nativesdk-nss-dev \
30     nativesdk-lua \
31     "
32
33 # required dependencies for Chromium build inside SDK (SPEC-942)
34 TOOLCHAIN_TARGET_TASK += " \
35     pciutils-dev \
36     ${@bb.utils.contains('DISTRO_FEATURES', 'pulseaudio', 'pulseaudio-dev' , '', d)} \
37     cairo-dev \
38     nss-dev \
39     cups-dev \
40     gconf-dev \
41     libexif-dev \
42     pango-dev \
43     libdrm-dev  \
44     lua-dev \
45     lua-staticdev \
46     libafb-helpers-staticdev \
47     libafb-helpers-qt-staticdev \
48     libappcontroller-staticdev \
49     ${@bb.utils.contains('LICENSE_FLAGS_WHITELIST', 'commercial', 'ffmpeg-dev', '', d)} \
50     "
51
52 # Add wayland-scanner to SDK (SPEC-945)
53 # Use TOOLCHAIN_HOST_TASK instead of adding to the packagegroup
54 # wayland-scanner is in nativesdk-wayland-dev !
55 # option: add also nativesdk-qtwayland-tools
56 TOOLCHAIN_HOST_TASK_append = " nativesdk-wayland nativesdk-wayland-dev"
57
58 TOOLCHAIN_HOST_TASK_append = " nativesdk-perl-modules "
59
60 # Add mosquitto to support building the telematics demo application.
61 # This is currently required for CI, as it uses agl-demo-platform-crosssdk
62 # to build everything. An agenda item has been tabled for the May 2019 F2F
63 # meeting to discuss the path forward (separate versus superset SDKs), this
64 # should be reviewed after that.
65 TOOLCHAIN_TARGET_TASK += "mosquitto-dev"
66
67 # Add nlohmann-json to support building the speech services.
68 # Required until either the agl-speech-framework feature is added as a
69 # dependency of agl-demo, or the speech services are migrated into the
70 # core profile.
71 TOOLCHAIN_TARGET_TASK += "nlohmann-json-dev"