Reworking packagegroups of AGL Distribution 95/4095/2
authorTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
Fri, 2 Oct 2015 05:02:06 +0000 (14:02 +0900)
committerTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
Fri, 2 Oct 2015 05:03:57 +0000 (14:03 +0900)
The recipe files and thier names are reworked by design of AGL
packagegroup.

For more details, see 'Packagegroups' section in README.md.

Change-Id: Ie7cd0efd1200c1a78d30ad6a834b9482487f0089
Signed-off-by: Tadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
13 files changed:
README.md
meta-agl/recipes-ivi/images/agl-image-ivi.bb
meta-ivi-common/recipes-core/packagegroups/packagegroup-ivi-common-core-automotive.bb [moved from meta-ivi-common/recipes-core/packagegroups/packagegroup-ivi-common-automotive.bb with 83% similarity]
meta-ivi-common/recipes-core/packagegroups/packagegroup-ivi-common-core-connectivity.bb [moved from meta-ivi-common/recipes-core/packagegroups/packagegroup-ivi-common-connectivity.bb with 83% similarity]
meta-ivi-common/recipes-core/packagegroups/packagegroup-ivi-common-core-graphics.bb [moved from meta-ivi-common/recipes-core/packagegroups/packagegroup-ivi-common-graphics.bb with 85% similarity]
meta-ivi-common/recipes-core/packagegroups/packagegroup-ivi-common-core-kernel.bb [moved from meta-ivi-common/recipes-core/packagegroups/packagegroup-ivi-common-kernel.bb with 84% similarity]
meta-ivi-common/recipes-core/packagegroups/packagegroup-ivi-common-core-multimedia.bb [moved from meta-ivi-common/recipes-core/packagegroups/packagegroup-ivi-common-multimedia.bb with 86% similarity]
meta-ivi-common/recipes-core/packagegroups/packagegroup-ivi-common-core-navi-lbs.bb [moved from meta-ivi-common/recipes-core/packagegroups/packagegroup-ivi-common-navi-lbs.bb with 85% similarity]
meta-ivi-common/recipes-core/packagegroups/packagegroup-ivi-common-core-os-commonlibs.bb [moved from meta-ivi-common/recipes-core/packagegroups/packagegroup-ivi-common-os-commonlibs.bb with 84% similarity]
meta-ivi-common/recipes-core/packagegroups/packagegroup-ivi-common-core-security.bb [moved from meta-ivi-common/recipes-core/packagegroups/packagegroup-ivi-common-security.bb with 84% similarity]
meta-ivi-common/recipes-core/packagegroups/packagegroup-ivi-common-core-speech-services.bb [moved from meta-ivi-common/recipes-core/packagegroups/packagegroup-ivi-common-speech-services.bb with 82% similarity]
meta-ivi-common/recipes-core/packagegroups/packagegroup-ivi-common-core.bb [new file with mode: 0644]
meta-ivi-common/recipes-core/packagegroups/packagegroup-ivi-common.bb [deleted file]

index 66de8c2..3fc7b98 100644 (file)
--- a/README.md
+++ b/README.md
@@ -52,7 +52,8 @@ Distribution and other platforms for In-Vehicle Infotainment system.
 `meta-agl` is a layer which contains AGL common and middleware packages.
 > meta-agl/meta-agl
 
-`meta-agl-bsp` is a layer which contains required packages to boot AGL distribution on an emulated machine(QEMU).
+`meta-agl-bsp` is a layer which contains required packages to boot AGL
+distribution on an emulated machine(QEMU).
 > meta-agl/meta-agl-bsp
 
 Packagegroups
@@ -60,29 +61,28 @@ Packagegroups
 
 AGL package group design:
 
-These are the top-level packagegroups for AGL Distribution.
-> packagegroup-agl-core  (minimal packages to boot system)
-> packagegroup-agl-ivi   (middlewares for AGL IVI)
-> packagegroup-ivi-common (common packages to AGL and others)
-
-Each package group can contain sub-package groups like these.
-> packagegroup-agl-core-multimedia
-> packagegroup-agl-core-connectivity
-> ...
-> packagegroup-agl-ivi-multimedia
-> packagegroup-agl-ivi-connectivity
-> ...
-> packagegroup-ivi-common-multimedia
-> packagegroup-ivi-common-connectivity
-
-The recipe for `packagegroup-ivi-common-*.bb` will contain common packages to
-AGL Distribution(meta-agl) and other In-Vehicle Infotainment system(e.g. meta-ivi and meta-tizen).
-> directory: meta-agl/meta-ivi-common/recipes-core/packagegroups
-> recipes  : packagegroup-ivi-common-[subsystem].bb
-
-The "packagegroups-agl-ivi-*" will contain AGL specific middleware packages.
-> directory: meta-agl/meta-agl/recipes-ivi/packagegroups
-> recipes  : packagegroup-agl-ivi-[subsystem].bb
+* packagegroup-agl-core*
+
+These are for making image ``agl-image-minimal`` which is small image just
+capable of allowing a device to boot.
+
+Subsystem should maintain packagegroup-agl-core-[subsystem].bb which should
+hold sufficient packages to build ``agl-image-minimal``.
+
+* packagegroup-agl-ivi*
+
+These are for making image ``agl-image-ivi`` which is baseline for IVI profile
+of AGL distro. 'Baseline' means Service Layer and Operating System Layer defined
+in AGL Spec v1.0. I think this is the same as GENIVI baseline.
+All packages which belong to AppHMI and Application Framework should be put
+into ``meta-agl-demo``.
+
+* packagegroup-ivi-common*
+
+These are for picking up some packages from GENIVI/Tizen/Others. The layer of
+``meta-ivi-common`` has no image to build, all packagegroups are aggregated
+to ``packagegrou-ivi-common-core' and it is included by images,
+``agl-image-ivi.bb`` and ``agl-demo-platform.bb``.
 
 Supported Machine
 -----------------
index 950b27a..9754906 100644 (file)
@@ -1,8 +1,8 @@
 SUMMARY = "A basic system of AGL distribution of IVI profile"
-require recipes-ivi/images/agl-image-ivi.inc
+require ${PN}.inc
 
 IMAGE_INSTALL_append = "\
     packagegroup-agl-core \
     packagegroup-agl-ivi \
-    packagegroup-ivi-common \
+    packagegroup-ivi-common-core \
     "
diff --git a/meta-ivi-common/recipes-core/packagegroups/packagegroup-ivi-common-core.bb b/meta-ivi-common/recipes-core/packagegroups/packagegroup-ivi-common-core.bb
new file mode 100644 (file)
index 0000000..b3cff10
--- /dev/null
@@ -0,0 +1,23 @@
+SUMMARY = "The middlewares for AGL IVI profile"
+DESCRIPTION = "A set of packagegroups which contain common packages required by AGL Distribution"
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+    packagegroup-ivi-common-core \
+    "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+    packagegroup-ivi-common-core-automotive \
+    packagegroup-ivi-common-core-connectivity \
+    packagegroup-ivi-common-core-graphics \
+    packagegroup-ivi-common-core-multimedia \
+    packagegroup-ivi-common-core-navi-lbs \
+    packagegroup-ivi-common-core-os-commonlibs \
+    packagegroup-ivi-common-core-speech-services \
+    packagegroup-ivi-common-core-security \
+    packagegroup-ivi-common-core-kernel \
+    "
diff --git a/meta-ivi-common/recipes-core/packagegroups/packagegroup-ivi-common.bb b/meta-ivi-common/recipes-core/packagegroups/packagegroup-ivi-common.bb
deleted file mode 100644 (file)
index 70d0fac..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
-SUMMARY = "The middlewares for AGL IVI profile"
-DESCRIPTION = "A set of packagegroups which contain common packages required by AGL Distribution"
-LICENSE = "MIT"
-
-inherit packagegroup
-
-PACKAGES = "\
-    packagegroup-ivi-common \
-    "
-
-ALLOW_EMPTY_${PN} = "1"
-
-RDEPENDS_${PN} += "\
-    packagegroup-ivi-common-automotive \
-    packagegroup-ivi-common-connectivity \
-    packagegroup-ivi-common-graphics \
-    packagegroup-ivi-common-multimedia \
-    packagegroup-ivi-common-navi-lbs \
-    packagegroup-ivi-common-os-commonlibs \
-    packagegroup-ivi-common-speech-services \
-    packagegroup-ivi-common-security \
-    packagegroup-ivi-common-kernel \
-    "