Follow-up removal of deprecated recipes after appfw removal 70/26870/4
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Wed, 17 Nov 2021 13:25:13 +0000 (14:25 +0100)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Sat, 20 Nov 2021 00:34:18 +0000 (00:34 +0000)
A follow-up cleanup to the previous changes.
- the aws+azure binders are deprecated in master, thus remove meta-iot-cloud
- meta-security is no longer a dependency
- rm agl-sota (due to meta-updater deprecation)
- rm agl-sign-wgts feature
- cleanup poky-agl.conf

Bug-AGL: SPEC-4121
Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Change-Id: I274179ab1fb74b274e955bd9a3eeccccac615770
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/26870
Tested-by: Jenkins Job builder account
ci-image-build: Jenkins Job builder account
ci-image-boot-test: Jenkins Job builder account
Reviewed-by: Scott Murray <scott.murray@konsulko.com>
16 files changed:
meta-agl-bsp/meta-iot-cloud/recipes-aws/aws-iot-device-sdk-embedded-c/aws-iot-device-sdk-embedded-c.bb [deleted file]
meta-agl-bsp/meta-iot-cloud/recipes-aws/aws-iot-device-sdk-embedded-c/files/Makefile.aws [deleted file]
meta-agl-bsp/meta-iot-cloud/recipes-aws/aws-iot-device-sdk-embedded-c/files/aws_iot_config.h [deleted file]
meta-agl-bsp/meta-iot-cloud/recipes-aws/aws-iot-device-sdk-embedded-c/files/awsiotsdk.pc [deleted file]
meta-agl-bsp/meta-iot-cloud/recipes-azure/azure-iot-sdk-c/azure-iot-sdk-c_%.bbappend [deleted file]
meta-agl-bsp/meta-iot-cloud/recipes-azure/azure-macro-utils-c/azure-macro-utils-c_%.bbappend [deleted file]
meta-agl-bsp/meta-iot-cloud/recipes-azure/umock-c/umock-c_%.bbappend [deleted file]
meta-agl-core/conf/distro/poky-agl.conf
meta-agl-core/conf/include/agl-devel.inc
meta-agl-core/recipes-platform/images/agl-image-minimal-crosssdk.inc
templates/feature/agl-sign-wgts/50_local.conf.inc [deleted file]
templates/feature/agl-sign-wgts/README_feature_agl-sign-wgts.md [deleted file]
templates/feature/agl-sota/50_bblayers.conf.inc [deleted file]
templates/feature/agl-sota/50_local.conf.inc [deleted file]
templates/feature/agl-sota/50_setup.sh [deleted file]
templates/feature/agl-sota/README_feature_agl-sota.md [deleted file]

diff --git a/meta-agl-bsp/meta-iot-cloud/recipes-aws/aws-iot-device-sdk-embedded-c/aws-iot-device-sdk-embedded-c.bb b/meta-agl-bsp/meta-iot-cloud/recipes-aws/aws-iot-device-sdk-embedded-c/aws-iot-device-sdk-embedded-c.bb
deleted file mode 100644 (file)
index a471928..0000000
+++ /dev/null
@@ -1,40 +0,0 @@
-DESCRIPTION = "AWS IoT device SDK for embedded C"
-AUTHOR = "AWS"
-HOMEPAGE = "https://github.com/aws/aws-iot-device-sdk-embedded-C"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=acc7a1bf87c055789657b148939e4b40"
-
-SRC_URI = "\
-    git://github.com/aws/aws-iot-device-sdk-embedded-C.git;protocol=https;branch=master \
-    file://Makefile.aws \
-    file://aws_iot_config.h \
-    file://awsiotsdk.pc \
-"
-SRCREV = "d039f075e1cc2a2a7fc20edc6868f328d8d36b2f"
-
-S = "${WORKDIR}/git"
-B = "${WORKDIR}/build"
-
-DEPENDS = "mbedtls"
-RDEPENDS:${PN} += "mbedtls"
-
-do_configure:prepend() {
-       cp ${WORKDIR}/Makefile.aws ${S}/src
-       cp ${WORKDIR}/aws_iot_config.h ${S}/include
-       cp ${WORKDIR}/awsiotsdk.pc ${S}
-}
-
-do_compile() {
-       cd ${S}/src
-       oe_runmake -f ./Makefile.aws DESTDIR=${D} all
-}
-
-do_install() {
-       cd ${S}/src
-       oe_runmake -f ./Makefile.aws DESTDIR=${D} install
-}
-
-BBCLASSEXTEND = "native nativesdk"
-
-ALLOW_EMPTY:${PN} = "1"
-
diff --git a/meta-agl-bsp/meta-iot-cloud/recipes-aws/aws-iot-device-sdk-embedded-c/files/Makefile.aws b/meta-agl-bsp/meta-iot-cloud/recipes-aws/aws-iot-device-sdk-embedded-c/files/Makefile.aws
deleted file mode 100644 (file)
index d4f18c0..0000000
+++ /dev/null
@@ -1,62 +0,0 @@
-###########################################################################
-# Copyright 2020 MERA
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-#     http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-###########################################################################
-
-# Generated library name
-NAME := awsiotsdk
-
-SRC = .
-AWS_SDK_DIR = $(SRC)/..
-PLATFORM_DIR = $(AWS_SDK_DIR)/platform/linux/mbedtls
-PLATFORM_COMMON_DIR = $(AWS_SDK_DIR)/platform/linux/common
-AWS_INSTALL_HEADERS_DIR = /usr/include/awsiotsdk
-
-
-CFLAGS += -I $(AWS_SDK_DIR)/include
-CFLAGS += -I $(AWS_SDK_DIR)/external_libs/jsmn
-CFLAGS += -I $(PLATFORM_COMMON_DIR)
-CFLAGS += -I $(PLATFORM_DIR)
-CFLAGS += -DENABLE_IOT_DEBUG -DENABLE_IOT_INFO -DENABLE_IOT_WARN -DENABLE_IOT_ERROR
-
-
-# Source to compile
-SRCS += $(wildcard $(SRC)/*.c)
-SRCS += $(wildcard $(AWS_SDK_DIR)/external_libs/jsmn/*.c)
-SRCS += $(wildcard $(PLATFORM_DIR)/*.c)
-SRCS += $(wildcard $(PLATFORM_COMMON_DIR)/*.c)
-
-OBJS = $(SRCS:.c=.o)
-
-
-.PHONY: all
-all: lib$(NAME).a
-
-lib$(NAME).a: $(OBJS)
-       $(AR) -rcs $@ $(OBJS)
-
-.PHONY: install
-install: lib$(NAME).a
-       install -D -m 0644 lib$(NAME).a $(DESTDIR)/usr/lib/lib$(NAME).a
-       install -d $(DESTDIR)$(AWS_INSTALL_HEADERS_DIR)
-       install -m 0644 $(AWS_SDK_DIR)/include/*.h $(DESTDIR)$(AWS_INSTALL_HEADERS_DIR)/
-       install -m 0644 $(AWS_SDK_DIR)/external_libs/jsmn/*.h $(DESTDIR)$(AWS_INSTALL_HEADERS_DIR)/
-       install -m 0644 $(PLATFORM_COMMON_DIR)/*.h $(DESTDIR)$(AWS_INSTALL_HEADERS_DIR)/
-       install -m 0644 $(PLATFORM_DIR)/*.h $(DESTDIR)$(AWS_INSTALL_HEADERS_DIR)/
-       install -d $(DESTDIR)/usr/lib/pkgconfig
-       install -m 0644 ../awsiotsdk.pc $(DESTDIR)/usr/lib/pkgconfig/ 
-
-.PHONY: clean
-clean:
-       -rm -f lib$(NAME).a $(OBJS)
diff --git a/meta-agl-bsp/meta-iot-cloud/recipes-aws/aws-iot-device-sdk-embedded-c/files/aws_iot_config.h b/meta-agl-bsp/meta-iot-cloud/recipes-aws/aws-iot-device-sdk-embedded-c/files/aws_iot_config.h
deleted file mode 100644 (file)
index e011893..0000000
+++ /dev/null
@@ -1,58 +0,0 @@
-/*
- * Copyright 2010-2015 Amazon.com, Inc. or its affiliates. All Rights Reserved.
- *
- * Licensed under the Apache License, Version 2.0 (the "License").
- * You may not use this file except in compliance with the License.
- * A copy of the License is located at
- *
- *  http://aws.amazon.com/apache2.0
- *
- * or in the "license" file accompanying this file. This file is distributed
- * on an "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either
- * express or implied. See the License for the specific language governing
- * permissions and limitations under the License.
- */
-
-/**
- * @file aws_iot_config.h
- * @brief AWS IoT specific configuration file
- */
-
-#ifndef AWS_IOT_CONFIG_H_
-#define AWS_IOT_CONFIG_H_
-
-// Get from console
-// =================================================
-#define AWS_IOT_MQTT_HOST              "" ///< Customer specific MQTT HOST. The same will be used for Thing Shadow
-#define AWS_IOT_MQTT_PORT              443 ///< default port for MQTT/S
-#define AWS_IOT_MQTT_CLIENT_ID         "" ///< MQTT client ID should be unique for every device
-#define AWS_IOT_MY_THING_NAME          "" ///< Thing Name of the Shadow this device is associated with
-#define AWS_IOT_ROOT_CA_FILENAME       "" ///< Root CA file name
-#define AWS_IOT_CERTIFICATE_FILENAME   "" ///< device signed certificate file name
-#define AWS_IOT_PRIVATE_KEY_FILENAME   "" ///< Device private key filename
-// =================================================
-
-// MQTT PubSub
-#define AWS_IOT_MQTT_TX_BUF_LEN 10240 ///< Any time a message is sent out through the MQTT layer. The message is copied into this buffer anytime a publish is done. This will also be used in the case of Thing Shadow
-#define AWS_IOT_MQTT_RX_BUF_LEN 10240 ///< Any message that comes into the device should be less than this buffer size. If a received message is bigger than this buffer size the message will be dropped.
-#define AWS_IOT_MQTT_NUM_SUBSCRIBE_HANDLERS 5 ///< Maximum number of topic filters the MQTT client can handle at any given time. This should be increased appropriately when using Thing Shadow
-
-// Thing Shadow specific configs
-#define SHADOW_MAX_SIZE_OF_RX_BUFFER (AWS_IOT_MQTT_RX_BUF_LEN+1) ///< Maximum size of the SHADOW buffer to store the received Shadow message, including terminating NULL byte.
-#define MAX_SIZE_OF_UNIQUE_CLIENT_ID_BYTES 80  ///< Maximum size of the Unique Client Id. For More info on the Client Id refer \ref response "Acknowledgments"
-#define MAX_SIZE_CLIENT_ID_WITH_SEQUENCE MAX_SIZE_OF_UNIQUE_CLIENT_ID_BYTES + 10 ///< This is size of the extra sequence number that will be appended to the Unique client Id
-#define MAX_SIZE_CLIENT_TOKEN_CLIENT_SEQUENCE MAX_SIZE_CLIENT_ID_WITH_SEQUENCE + 20 ///< This is size of the the total clientToken key and value pair in the JSON
-#define MAX_ACKS_TO_COMEIN_AT_ANY_GIVEN_TIME 10 ///< At Any given time we will wait for this many responses. This will correlate to the rate at which the shadow actions are requested
-#define MAX_THINGNAME_HANDLED_AT_ANY_GIVEN_TIME 10 ///< We could perform shadow action on any thing Name and this is maximum Thing Names we can act on at any given time
-#define MAX_JSON_TOKEN_EXPECTED 120 ///< These are the max tokens that is expected to be in the Shadow JSON document. Include the metadata that gets published
-#define MAX_SHADOW_TOPIC_LENGTH_WITHOUT_THINGNAME 60 ///< All shadow actions have to be published or subscribed to a topic which is of the format $aws/things/{thingName}/shadow/update/accepted. This refers to the size of the topic without the Thing Name
-#define MAX_SIZE_OF_THING_NAME 30 ///< The Thing Name should not be bigger than this value. Modify this if the Thing Name needs to be bigger
-#define MAX_SHADOW_TOPIC_LENGTH_BYTES MAX_SHADOW_TOPIC_LENGTH_WITHOUT_THINGNAME + MAX_SIZE_OF_THING_NAME ///< This size includes the length of topic with Thing Name
-
-// Auto Reconnect specific config
-#define AWS_IOT_MQTT_MIN_RECONNECT_WAIT_INTERVAL 1000 ///< Minimum time before the First reconnect attempt is made as part of the exponential back-off algorithm
-#define AWS_IOT_MQTT_MAX_RECONNECT_WAIT_INTERVAL 128000 ///< Maximum time interval after which exponential back-off will stop attempting to reconnect.
-
-#define DISABLE_METRICS true ///< Disable the collection of metrics by setting this to true
-
-#endif /* AWS_IOT_CONFIG_H_ */
diff --git a/meta-agl-bsp/meta-iot-cloud/recipes-aws/aws-iot-device-sdk-embedded-c/files/awsiotsdk.pc b/meta-agl-bsp/meta-iot-cloud/recipes-aws/aws-iot-device-sdk-embedded-c/files/awsiotsdk.pc
deleted file mode 100644 (file)
index f838499..0000000
+++ /dev/null
@@ -1,27 +0,0 @@
-###########################################################################
-# Copyright 2020 MERA
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-#     http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-###########################################################################
-
-prefix=/usr
-exec_prefix=${prefix}
-libdir=${prefix}/lib
-includedir=${prefix}/include/awsiotsdk
-
-Name: AWS IoT Device SDK for Embedded C
-Description: AWS IoT SDK compiled into library (includes mbedTLS and jsmn code)
-Version: 3.0.1
-
-Cflags: -I${includedir} -DENABLE_IOT_DEBUG -DENABLE_IOT_INFO -DENABLE_IOT_WARN -DENABLE_IOT_ERROR
-Libs: -L${libdir} -lawsiotsdk -lmbedtls -lmbedcrypto -lmbedx509
diff --git a/meta-agl-bsp/meta-iot-cloud/recipes-azure/azure-iot-sdk-c/azure-iot-sdk-c_%.bbappend b/meta-agl-bsp/meta-iot-cloud/recipes-azure/azure-iot-sdk-c/azure-iot-sdk-c_%.bbappend
deleted file mode 100644 (file)
index 58d4693..0000000
+++ /dev/null
@@ -1,5 +0,0 @@
-# Disable the amqp transport, due to linking error in meta-iot repository for amqp
-# symbols from amqp code are not included in the libiothub_client.so
-
-# NOTE: amqp is not used by AGL in IoT context at the moment
-PACKAGECONFIG:remove = "amqp"
diff --git a/meta-agl-bsp/meta-iot-cloud/recipes-azure/azure-macro-utils-c/azure-macro-utils-c_%.bbappend b/meta-agl-bsp/meta-iot-cloud/recipes-azure/azure-macro-utils-c/azure-macro-utils-c_%.bbappend
deleted file mode 100644 (file)
index b90c754..0000000
+++ /dev/null
@@ -1 +0,0 @@
-ALLOW_EMPTY:${PN} = "1"
diff --git a/meta-agl-bsp/meta-iot-cloud/recipes-azure/umock-c/umock-c_%.bbappend b/meta-agl-bsp/meta-iot-cloud/recipes-azure/umock-c/umock-c_%.bbappend
deleted file mode 100644 (file)
index b90c754..0000000
+++ /dev/null
@@ -1 +0,0 @@
-ALLOW_EMPTY:${PN} = "1"
index 83dbde8..4947308 100644 (file)
@@ -149,13 +149,6 @@ AGL_DEFAULT_INITRAMFS_FSTYPES ?= "ext4.gz"
 IMAGE_FSTYPES = "${AGL_DEFAULT_IMAGE_FSTYPES} ${AGL_EXTRA_IMAGE_FSTYPES}"
 INITRAMFS_FSTYPES = "${AGL_DEFAULT_INITRAMFS_FSTYPES} ${AGL_EXTRA_INITRAMFS_FSTYPES}"
 #
-# THE FUTURE is 'wic'
-# IMAGE_FSTYPES:append = " wic"
-
-# Complementary package definitions for agl-test-wgt and agl-devel-wgt
-# image features
-COMPLEMENTARY_GLOB[agl-test-wgt] = '*-test'
-COMPLEMENTARY_GLOB[agl-devel-wgt] = '*-coverage *-debug'
 
 # Fix for rpm metadata clash between nativesdk-cmake and nativesdk-qtbase-tools
 # (revalidate after 2017-10-15, 2018-06-12: still required)
@@ -166,21 +159,3 @@ DIRFILES:pn-nativesdk-cmake = "1"
 # This needs to be verified.
 do_package_write_rpm[vardepsexclude] += "ARCHIVER_TOPDIR PF"
 
-# Set preferred provider to new navi application
-PREFERRED_RPROVIDER_virtual/navigation ?= "ondemandnavi"
-
-# Set preferred provider for low-can device mapping configuration
-PREFERRED_RPROVIDER_virtual/low-can-dev-mapping ?= "dev-mapping"
-
-# Mask upstream meta-security bbappend that interferes with non-linux-yocto
-# kernels due to the bug of having two wildcards, which bitbake does not
-# support. Not having it is not an issue, since there is also explicit
-# enabling of required security features done by meta-agl/meta-security.
-BBMASK += "meta-security/recipes-kernel/linux/linux-%_5.%.bbappend"
-
-# Workaround for https://jira.automotivelinux.org/browse/SPEC-3621
-# TLDR: do_image_wic will modify the target's /etc/fstab while
-# do_image_tar and do_image_ext4 can run in parallel
-# This needs to be fixed upstream:
-# See https://bugzilla.yoctoproject.org/show_bug.cgi?id=13994
-INHERIT += "image_types_wic_workaround"
index 394ff07..afc2844 100644 (file)
@@ -7,8 +7,6 @@ IMAGE_INSTALL:append = " \
 # Install libdrm-test, including modetest, to images with GUI
 IMAGE_INSTALL:append = "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', ' libdrm-tests', '', d)}"
 
-IMAGE_FEATURES:append = " agl-devel-wgt"
-
 # disable install of debug files in SDK
 # initial value: SDKIMAGE_FEATURES="dev-pkgs dbg-pkgs staticdev-pkgs"
 SDKIMAGE_FEATURES="dev-pkgs"
index 8695d8d..bab27eb 100644 (file)
@@ -1,24 +1,2 @@
 IMAGE_FEATURES:append = " dev-pkgs"
 IMAGE_INSTALL:append = " kernel-dev kernel-devsrc"
-
-
-
-
-
-
-# FIXME:
-# Always include the test widgets
-#IMAGE_FEATURES:append = " agl-test-wgt"
-#
-# Required dependencies for app and test builds
-#TOOLCHAIN_HOST_TASK += " \
-#    nativesdk-lua \
-#    "
-#
-# Required dependencies for app and test builds
-#TOOLCHAIN_TARGET_TASK += " \
-#    lua-dev \
-#    lua-staticdev \
-#    libafb-helpers-staticdev \
-#    libappcontroller-staticdev \
-#    "
diff --git a/templates/feature/agl-sign-wgts/50_local.conf.inc b/templates/feature/agl-sign-wgts/50_local.conf.inc
deleted file mode 100644 (file)
index fb1f6ab..0000000
+++ /dev/null
@@ -1,2 +0,0 @@
-#see meta-agl/meta-agl/conf/include/agl-sign-wgts.inc
-require conf/include/agl-sign-wgts.inc
diff --git a/templates/feature/agl-sign-wgts/README_feature_agl-sign-wgts.md b/templates/feature/agl-sign-wgts/README_feature_agl-sign-wgts.md
deleted file mode 100644 (file)
index 5e3b4b1..0000000
+++ /dev/null
@@ -1,8 +0,0 @@
----
-description: Feature agl-sign-wgts
-authors: José Bollo <jose.bollo@iot.bzh>, 
----
-       
-### Feature agl-sign-wgts
-        
-Activation of the signature of wgt files
diff --git a/templates/feature/agl-sota/50_bblayers.conf.inc b/templates/feature/agl-sota/50_bblayers.conf.inc
deleted file mode 100644 (file)
index f362335..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-BBLAYERS =+ " \
-       ${METADIR}/external/meta-updater \
-       "
diff --git a/templates/feature/agl-sota/50_local.conf.inc b/templates/feature/agl-sota/50_local.conf.inc
deleted file mode 100644 (file)
index 8019022..0000000
+++ /dev/null
@@ -1,8 +0,0 @@
-# See meta-updater/conf/distro/sota.conf.inc
-INHERIT += "sota"
-DISTRO_FEATURES:append = " sota usrmerge"
-DISTRO_FEATURES_NATIVE:append = " sota"
-AGL_DEFAULT_INITRAMFS_FSTYPES = "cpio.gz"
-# Netboot is not obeying usrmerge distro feature
-# therefore it is not compatible with agl-sota
-CONFLICT_DISTRO_FEATURES += "netboot"
diff --git a/templates/feature/agl-sota/50_setup.sh b/templates/feature/agl-sota/50_setup.sh
deleted file mode 100644 (file)
index 76cb016..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
-
-cat <<EOF >> ${BUILDDIR}/conf/bblayers.conf
-
-# # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # #
-# fragment {
-# ${METADIR}/meta-agl/templates/feature/agl-sota/50_setup.sh
-#
-EOF
-
-case ${MACHINE} in
-       "qemux86-64")
-         echo "BBLAYERS =+ \"\${METADIR}/external/meta-updater-qemux86-64\"" >> ${BUILDDIR}/conf/bblayers.conf;;
-       "raspberrypi4")
-         echo "BBLAYERS =+ \"\${METADIR}/external/meta-updater-raspberrypi\"" >> ${BUILDDIR}/conf/bblayers.conf;;
-       *)
-         echo "#No extra SOTA feature layer for MACHINE ${MACHINE}" >> ${BUILDDIR}/conf/bblayers.conf;;
-esac
-
-
-cat <<EOF >> ${BUILDDIR}/conf/bblayers.conf
-
-#
-# }
-# # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # #
-
-EOF
diff --git a/templates/feature/agl-sota/README_feature_agl-sota.md b/templates/feature/agl-sota/README_feature_agl-sota.md
deleted file mode 100644 (file)
index beeffc2..0000000
+++ /dev/null
@@ -1,9 +0,0 @@
----
-description: Feature agl-sota
-authors: Anton Gerasimov <anton@advancedtelematic.com>, Changhyeok Bae <changhyeok.bae@gmail.com>, Jan-Simon Moeller <jsmoeller@linuxfoundation.org>, Jan-Simon Möller <jsmoeller@linuxfoundation.org>, Leon Anavi <leon.anavi@konsulko.com>, Phil Wise <phil@advancedtelematic.com>, Ronan Le Martret <ronan.lemartret@iot.bzh>
----
-       
-### Feature agl-sota
-        
-*Description is missing - please complete file meta-agl/templates/feature/agl-sota/README_feature_agl-sota.md*
-