Fix a couple of override syntax issues 74/26874/2
authorScott Murray <scott.murray@konsulko.com>
Wed, 17 Nov 2021 21:05:20 +0000 (16:05 -0500)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Thu, 18 Nov 2021 15:18:51 +0000 (15:18 +0000)
Fix a couple of spots where use of the old-style override syntax has
accidentally been added.

Bug-AGL: SPEC-4052

Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Change-Id: I7f4d5b0ba0bf813f3e72b783e30cadc5ba0e030d
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/26874
Tested-by: Jenkins Job builder account
ci-image-build: Jenkins Job builder account
ci-image-boot-test: Jenkins Job builder account
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
meta-agl-bsp/meta-rcar-gen3/recipes-platform/packagegroups/packagegroup-agl-graphical-multimedia.bbappend
meta-agl-core/recipes-graphics/wayland/weston-init_aglcore.inc

index bcf15fa..53eb1c5 100644 (file)
@@ -1,4 +1,4 @@
-RDEPENDS_${PN}:append:rcar-gen3 = "\
+RDEPENDS:${PN}:append:rcar-gen3 = "\
     ${@bb.utils.contains('MACHINE_FEATURES','multimedia','packagegroup-multimedia-kernel-modules','',d)} \
     ${@bb.utils.contains('MACHINE_FEATURES','multimedia','packagegroup-multimedia-libs','',d)} \
     ${@bb.utils.contains('MACHINE_FEATURES','multimedia','packagegroup-gstreamer1.0-plugins','',d)} \
index 070f5f8..8966700 100644 (file)
@@ -43,12 +43,12 @@ inherit useradd
 
 USERADD_PACKAGES = "${PN}"
 
-FILES_${PN} += "\
+FILES:${PN} += "\
     ${systemd_system_unitdir}/weston.service \
     ${systemd_system_unitdir}/weston.socket \
     /home/weston \
 "
 
-SYSTEMD_SERVICE_${PN} = "weston.service weston.socket"
-USERADD_PARAM_${PN} = "--home /home/weston --shell /bin/sh --user-group -G video,input weston"
-GROUPADD_PARAM_${PN} = "-r wayland"
+SYSTEMD_SERVICE:${PN} = "weston.service weston.socket"
+USERADD_PARAM:${PN} = "--home /home/weston --shell /bin/sh --user-group -G video,input weston"
+GROUPADD_PARAM:${PN} = "-r wayland"