meta-agl-bsp/core: mesa: generic patches should be y-c-l safe 41/28741/2
authorDenys Dmytriyenko <denys@konsulko.com>
Mon, 1 May 2023 15:07:47 +0000 (15:07 +0000)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Wed, 3 May 2023 15:27:26 +0000 (15:27 +0000)
SPEC-4724 added a generic backported patch to mesa. But instead of
adding it directly to mesa_%.bbappend, it should have been added to
mesa_agl.inc which is only active when "aglcore" feature is enabled,
making it yocto-check-layer safe.

Bug-AGL: SPEC-4723

Change-Id: I226cba14de917f6e4109d1dc1df364cb74e7ee45
Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/28741
Reviewed-by: Marius Vlad <marius.vlad@collabora.com>
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tested-by: Jenkins Job builder account
ci-image-build: Jenkins Job builder account
ci-image-boot-test: Jenkins Job builder account

meta-agl-bsp/meta-core/recipes-graphics/mesa/mesa_%.bbappend
meta-agl-bsp/meta-core/recipes-graphics/mesa/mesa_agl.inc

index 27dd783..fb797a4 100644 (file)
@@ -1,5 +1,3 @@
 FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
 
-SRC_URI += "file://0001-virgl-don-t-a-use-staging-when-a-resources-created-w.patch"
-
 require ${@bb.utils.contains('AGL_FEATURES', 'aglcore', '${BPN}_agl.inc', '', d)}
index e747613..c0f5b27 100644 (file)
@@ -1,3 +1,5 @@
+SRC_URI += "file://0001-virgl-don-t-a-use-staging-when-a-resources-created-w.patch"
+
 # The gallium-llvm is recommended as software 3D graphics renderer
 GALLIUM_LLVM = "gallium-llvm"
 PACKAGECONFIG:append:qemux86 = " gallium ${GALLIUM_LLVM}"