meta-ti-bsp: ti-sgx-ddk-um: drop systemd service workaround 40/28740/2
authorDenys Dmytriyenko <denys@konsulko.com>
Mon, 1 May 2023 15:01:57 +0000 (15:01 +0000)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Wed, 3 May 2023 15:27:26 +0000 (15:27 +0000)
Latest TI graphics package uses udev rules to initialize the driver
and does not install legacy SysVinit rc.pvr script unless udev isn't
available. No need for systemd service workaround anymore.

Bug-AGL: SPEC-4723

Change-Id: I3ce5d270357578086152d87fb2cf91512691e1a9
Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/28740
Tested-by: Jenkins Job builder account
ci-image-build: Jenkins Job builder account
ci-image-boot-test: Jenkins Job builder account
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
meta-agl-bsp/meta-ti-bsp/recipes-graphics/libgles/ti-sgx-ddk-um/pvr.service [deleted file]
meta-agl-bsp/meta-ti-bsp/recipes-graphics/libgles/ti-sgx-ddk-um_%.bbappend [deleted file]

diff --git a/meta-agl-bsp/meta-ti-bsp/recipes-graphics/libgles/ti-sgx-ddk-um/pvr.service b/meta-agl-bsp/meta-ti-bsp/recipes-graphics/libgles/ti-sgx-ddk-um/pvr.service
deleted file mode 100644 (file)
index 1acb94f..0000000
+++ /dev/null
@@ -1,19 +0,0 @@
-[Unit]
-Description=PVR service
-SourcePath=/etc/ti-sgx/rc.pvr
-DefaultDependencies=no
-Before=psplash-start.service
-
-[Service]
-Type=forking
-Restart=no
-TimeoutSec=5min
-IgnoreSIGPIPE=no
-KillMode=process
-GuessMainPID=no
-RemainAfterExit=yes
-ExecStart=/etc/ti-sgx/rc.pvr start
-ExecStop=/etc/ti-sgx/rc.pvr stop
-
-[Install]
-WantedBy=sysinit.target
diff --git a/meta-agl-bsp/meta-ti-bsp/recipes-graphics/libgles/ti-sgx-ddk-um_%.bbappend b/meta-agl-bsp/meta-ti-bsp/recipes-graphics/libgles/ti-sgx-ddk-um_%.bbappend
deleted file mode 100644 (file)
index 86e3534..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
-FILESEXTRAPATHS:append := ":${THISDIR}/${PN}"
-FILES:${PN} += "/etc/ti-sgx/"
-
-SRC_URI:append = "\
-    file://pvr.service \
-"
-
-inherit systemd
-
-SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE:${PN} = "pvr.service"
-
-do_install:append() {
-       install -d ${D}${systemd_system_unitdir}
-       install -m 0755 ${WORKDIR}/pvr.service ${D}${systemd_system_unitdir}
-       install -d ${D}${sysconfdir}/ti-sgx
-       install -m 0755 ${D}${sysconfdir}/init.d/rc.pvr ${D}${sysconfdir}/ti-sgx
-}