meta-agl-bsp: fix rcar3 packaging errors 29/27429/2
authorScott Murray <scott.murray@konsulko.com>
Fri, 29 Apr 2022 16:29:11 +0000 (12:29 -0400)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tue, 3 May 2022 21:36:16 +0000 (21:36 +0000)
Provide a default value of PACKAGE_ARCH for the packagegroup
packagegroup-multimedia-libs from meta-rcar-gen3 to avoids errors from
a new packaging QA check with respect to packagegroups depending on
versioned library packages needing to be machine-specific.

Note that this needs to be done in global configuration space as
opposed to in a bbappend because the value needs to be set before the
packagegroup bbclass is inherited.  This can be removed when upstream
is fixed to add the required PACKAGE_ARCH = "${MACHINE_ARCH}".

Bug-AGL: SPEC-4343

Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Change-Id: I60dc1fbb976c7e08b174017268949dc43d6d17fe
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/27429
Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
meta-agl-bsp/conf/include/agl_rcar-nogfx.inc

index 48706ca..476eb9c 100644 (file)
@@ -48,3 +48,13 @@ BBMASK += "meta-rcar-gen3/recipes-core/base-files/ meta-rcar-gen3/recipes-core/s
 
 # Mask out cogl bbappend to avoid meta-gnome dependency
 BBMASK += "meta-rcar-gen3/recipes-graphics/cogl/cogl-1.0_1.%.bbappend"
+
+# Provide default value that avoids errors from a new packaging QA
+# check with respect to packagegroups depending on versioned library
+# packages needing to be machine-specific.
+#
+# Note that this needs to be done here in global configuration space as
+# opposed to in a bbappend because the value needs to be set before the
+# packagegroup bbclass is inherited.  This can be removed when upstream
+# is fixed to add the required PACKAGE_ARCH = "${MACHINE_ARCH}".
+PACKAGE_ARCH:pn-packagegroup-multimedia-libs = "${MACHINE_ARCH}"