meta-agl-bsp: avoid meta-gnome dependency from meta-rcar-gen3 28/27428/2
authorScott Murray <scott.murray@konsulko.com>
Fri, 29 Apr 2022 16:16:55 +0000 (12:16 -0400)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tue, 3 May 2022 21:36:16 +0000 (21:36 +0000)
The kirkstone-dev_3.5_M3_v5.9.0 branch of meta-renesas contains a
new bbappend for cogl which requires meta-gnome.  Since nothing
in the BSP layer itself depends on cogl, and there is currently
no obvious usecase for cogl outside of GNOME desktop related
libraries, BBMASK out the bbappend so we do not need to pull in
meta-gnome.  This can be revisited if an AGL member presents a need
for cogl on rcar3 in their downstream use of AGL.  Ideally, upstream
will move the bbappend to a dynamic layer directory to remove the
issue.

Bug-AGL: SPEC-4343

Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Change-Id: I6e55c07d1ff1fd7d68d1798ecca3c9c1b35cdf14
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/27428
Reviewed-by: Vasyl Vavrychuk <vasyl.vavrychuk@opensynergy.com>
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
meta-agl-bsp/conf/include/agl_rcar-nogfx.inc

index eb29f1a..48706ca 100644 (file)
@@ -45,3 +45,6 @@ PSEUDO_IGNORE_PATHS:append:pn-kernel-module-vspm = ",${KERNELSRC}"
 # Mask out base-files and systemd bbappends to avoid changing systemd-tmpfiles
 # behavior, see SPEC-4256 for a more involved explanation.
 BBMASK += "meta-rcar-gen3/recipes-core/base-files/ meta-rcar-gen3/recipes-core/systemd/"
+
+# Mask out cogl bbappend to avoid meta-gnome dependency
+BBMASK += "meta-rcar-gen3/recipes-graphics/cogl/cogl-1.0_1.%.bbappend"