graphics: Add agl-compositor recipe 40/23040/5
authorDaniel Stone <daniels@collabora.com>
Mon, 25 Nov 2019 13:15:30 +0000 (13:15 +0000)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tue, 26 Nov 2019 17:52:05 +0000 (17:52 +0000)
Add a recipe for the new AGL compositor and enable it when building the
Weston package group.

Change-Id: I3fe88370a4fc6a01b8ba8c3126a407cd9c39a842
Signed-off-by: Daniel Stone <daniels@collabora.com>
meta-agl-profile-graphical/recipes-graphics/wayland/agl-compositor_git.bb [new file with mode: 0644]
meta-agl-profile-graphical/recipes-platform/packagegroups/packagegroup-agl-graphical-weston.bb

diff --git a/meta-agl-profile-graphical/recipes-graphics/wayland/agl-compositor_git.bb b/meta-agl-profile-graphical/recipes-graphics/wayland/agl-compositor_git.bb
new file mode 100644 (file)
index 0000000..f42b288
--- /dev/null
@@ -0,0 +1,21 @@
+SUMMARY = "Reference Wayland compositor for AGL"
+DESCRIPTION = "The AGL compositor is a reference Wayland server for Automotive \
+Grade Linux, using libweston as a base to provide a graphical environment for \
+the automotive environment."
+
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/q/project:src%252Fagl-compositor"
+SECTION = "x11"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=fac6abe0003c4d142ff8fa1f18316df0"
+
+DEPENDS = "wayland wayland-protocols wayland-native weston"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/agl-compositor.git;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "aa4ba5d283d641da25722af7a966c31d61a9686b"
+
+PV = "0.0.10+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+inherit meson pkgconfig python3native
+
+FILES_${PN} = "${bindir}/agl-compositor"
index 53721f0..a97b6eb 100644 (file)
@@ -17,5 +17,6 @@ RDEPENDS_${PN} += " \
                   weston-ready \
                   agl-login-manager \
                   agl-desktop-config \
+                  agl-compositor \
                   "