weston: Add patch to export more config-parser API 39/23039/2
authorDaniel Stone <daniels@collabora.com>
Mon, 25 Nov 2019 12:30:34 +0000 (12:30 +0000)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tue, 26 Nov 2019 17:51:09 +0000 (17:51 +0000)
Used by the AGL compositor to implement configuration parsing.

Change-Id: I30b207f23bbc252dfee30ddf90d84e02779b0395
Upstream: https://gitlab.freedesktop.org/wayland/weston/merge_requests/314
Signed-off-by: Daniel Stone <daniels@collabora.com>
meta-agl-profile-graphical/recipes-graphics/wayland/weston/0001-config-parser-Export-get_full_path-and-destroy.patch [new file with mode: 0644]
meta-agl-profile-graphical/recipes-graphics/wayland/weston_6.0.0.bbappend

diff --git a/meta-agl-profile-graphical/recipes-graphics/wayland/weston/0001-config-parser-Export-get_full_path-and-destroy.patch b/meta-agl-profile-graphical/recipes-graphics/wayland/weston/0001-config-parser-Export-get_full_path-and-destroy.patch
new file mode 100644 (file)
index 0000000..9dbd7a7
--- /dev/null
@@ -0,0 +1,36 @@
+From 40ff644ac4da90c5cf5239c6ee6051d9bb2b099a Mon Sep 17 00:00:00 2001
+From: Daniel Stone <daniels@collabora.com>
+Date: Mon, 25 Nov 2019 10:30:11 +0000
+Subject: [PATCH] config-parser: Export get_full_path and destroy
+
+Make sure we export the get_full_path() accessor (declared in the
+header, used by Weston itself) and the parser's destroy function.
+
+Signed-off-by: Daniel Stone <daniels@collabora.com>
+---
+ shared/config-parser.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/shared/config-parser.c b/shared/config-parser.c
+index 35f09f006..94eb24cc1 100644
+--- a/shared/config-parser.c
++++ b/shared/config-parser.c
+@@ -470,6 +470,7 @@ weston_config_parse(const char *name)
+       return config;
+ }
++WL_EXPORT
+ const char *
+ weston_config_get_full_path(struct weston_config *config)
+ {
+@@ -500,6 +501,7 @@ weston_config_next_section(struct weston_config *config,
+       return 1;
+ }
++WL_EXPORT
+ void
+ weston_config_destroy(struct weston_config *config)
+ {
+-- 
+2.21.0
+
index 9e29e27..4e7e1d8 100644 (file)
@@ -4,6 +4,7 @@ SRC_URI_append = "\
     file://0001-Allow-regular-users-to-launch-Weston_2.0.0.patch \
     file://use-XDG_RUNTIMESHARE_DIR.patch \
     file://0003-compositor-drm-introduce-drm_get_dmafd_from_view.patch \
+    file://0001-config-parser-Export-get_full_path-and-destroy.patch \
     "
 # Disabled until SPEC-2827 H3ULCB v3.0 + Kingfisher issue is debugged:
 #   file://0002-compositor-add-output-type-to-weston_output.patch