af-main: OAuth client credentials and localuser names 56/23356/5
authorJosé Bollo <jose.bollo@iot.bzh>
Tue, 17 Dec 2019 18:56:16 +0000 (19:56 +0100)
committerJosé Bollo <jose.bollo@iot.bzh>
Thu, 19 Dec 2019 14:03:32 +0000 (15:03 +0100)
This includes:
 - the basic OAuth client credential server
 - the token logic for WAM apps
 - the use of localuser names WAM apps

Bug-AGL: SPEC-2968
Bug-AGL: SPEC-3032
Bug-AGL: SPEC-3033
Bug-AGL: SPEC-3014

Change-Id: I37588d4a4f9b74bb0ab0da70c7fbae1f8979f25e
Signed-off-by: José Bollo <jose.bollo@iot.bzh>
meta-app-framework/recipes-core/af-main/af-main/Hack-to-allow-the-debugging.patch [deleted file]
meta-app-framework/recipes-core/af-main/af-main_git.bb
meta-app-framework/recipes-core/af-main/af-main_git.inc

diff --git a/meta-app-framework/recipes-core/af-main/af-main/Hack-to-allow-the-debugging.patch b/meta-app-framework/recipes-core/af-main/af-main/Hack-to-allow-the-debugging.patch
deleted file mode 100644 (file)
index 14a26fb..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
-From a4fbfb88f1b7c4f4287d9279767220fae80d26da Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Jos=C3=A9=20Bollo?= <jose.bollo@iot.bzh>
-Date: Thu, 21 Jan 2016 15:07:29 +0100
-Subject: [PATCH] Hack to allow the debugging
-
-This is a temporarily fix to continue debugging
-afm-main. This should be removed later.
-
-Change-Id: I2f10f0cb1fce2ee30bd0754ad2e7bc8e2f6513aa
----
- conf/afm-user-daemon.conf | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/conf/user/afm-user-daemon.conf b/conf/user/afm-user-daemon.conf
-index 801c7ae..98a3152 100644
---- a/conf/user/afm-user-daemon.conf
-+++ b/conf/user/afm-user-daemon.conf
-@@ -25,7 +25,7 @@
-         </policy>
-         <policy context="default">
--                <deny own="org.AGL.afm.user"/>
-+                <allow own="org.AGL.afm.user"/>
-                 <allow send_destination="org.AGL.afm.system"/>
-         </policy>
--- 
-2.1.4
-
index 4a56545..6e44c49 100644 (file)
@@ -12,7 +12,7 @@ SECTION = "base"
 
 DEPENDS = "openssl libxml2 xmlsec1 systemd libzip json-c systemd security-manager af-binder sed m4"
 DEPENDS_class-native = "openssl libxml2 xmlsec1 libzip json-c"
-RDEPENDS_${PN}_class-target += "af-binder-tools"
+RDEPENDS_${PN}_class-target += "af-binder-tools nss-localuser cynagoauth"
 
 PACKAGE_WRITE_DEPS_append_with-lsm-smack = " smack-native libcap-native"
 
@@ -68,11 +68,6 @@ GROUPADD_PARAM_${PN} = "--system ${afm_name}"
 RDEPENDS_${PN}_append_with-lsm-smack = " smack bash"
 DEPENDS_append_with-lsm-smack = " smack-native"
 
-# short hacks here
-SRC_URI += "\
-       file://Hack-to-allow-the-debugging.patch \
-"
-
 do_install_append_class-target() {
     install -d ${D}${bindir}
     install -d -m 0775 ${D}${systemd_units_root}/system
index a20132e..337f474 100644 (file)
@@ -10,7 +10,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=3b83ef96387f14655fc854ddc3c6bd57"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/app-framework-main;protocol=https;branch=${AGL_BRANCH}"
 
-SRCREV = "b65d4e0061d77718ee6c04c6cd1d41f6940b5a03"
+SRCREV = "e847f14c7688f43b5f74e7362dcd5d4714e98bd3"
 PV = "${AGL_BRANCH}+git${SRCPV}"
 
 S = "${WORKDIR}/git"