cynagoauth: Add a basic OAuth server 09/23409/3
authorJosé Bollo <jose.bollo@iot.bzh>
Tue, 17 Dec 2019 18:41:11 +0000 (19:41 +0100)
committerJosé Bollo <jose.bollo@iot.bzh>
Thu, 19 Dec 2019 14:03:32 +0000 (15:03 +0100)
cynagoauth is a basic OAuth2 server implementing
delivery of tokens based on the Smack label of the
client.

Bug-AGL: SPEC-2550
Bug-AGL: SPEC-2968
Bug-AGL: SPEC-3032

Change-Id: I93aa1864ac68ec51963a25e80150879ea88a5766
Signed-off-by: José Bollo <jose.bollo@iot.bzh>
meta-security/recipes-security/cynagoauth/cynagoauth_0.1.bb [new file with mode: 0644]

diff --git a/meta-security/recipes-security/cynagoauth/cynagoauth_0.1.bb b/meta-security/recipes-security/cynagoauth/cynagoauth_0.1.bb
new file mode 100644 (file)
index 0000000..c77c991
--- /dev/null
@@ -0,0 +1,23 @@
+DESCRIPTION = "OAuth server using cynagora backend"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/cynagoauth.git;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "26a5dbddf3a9bfde481a6fcd2aae16c7ecba665f"
+PV = "0.1+git${SRCPV}"
+
+S = "${WORKDIR}/git"
+
+DEPENDS = "json-c libmicrohttpd openssl cynagora"
+
+inherit cmake
+
+EXTRA_OECMAKE += " \
+       -DDEFAULTHOSTS=:7777 \
+       -DDEFAULTURL=http://localhost:7777/tok \
+       -DUNITDIR_SYSTEM=${systemd_system_unitdir} \
+"
+
+FILES_${PN} += "${systemd_system_unitdir}"
+
+