Make it possible to use systemd-coredump for development 57/16257/2
authorTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
Wed, 22 Aug 2018 16:12:02 +0000 (16:12 +0000)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Thu, 23 Aug 2018 12:07:38 +0000 (12:07 +0000)
For development, systemd-coredump should be enabled especially
for meta-agl/meta-agl-demo because all applications which
compatible with agl appfw are running on systemd.

This patch make systemd-coredump available when
agl-devel is set on (run aglsetup.sh with 'agl-devel').

The core dump files are stored in /var/lib/systemd/coredump/
and 'coredumpctl' is helpful to use dump files.

Change-Id: Ic8a011e96fe36be0266389c03d761d1b8e78bf68
Signed-off-by: Tadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
meta-agl-profile-core/files/group
meta-agl-profile-core/files/passwd
meta-agl-profile-core/recipes-core/systemd/systemd_%.bbappend

index f8a3843..77fb6eb 100644 (file)
@@ -52,6 +52,7 @@ weston-launch::986:
 lock::990:
 systemd-journal::989:
 systemd-timesync::988:
+systemd-coredump::888:
 pulse::991:
 bind::987:
 trinity::985:
index 754cb81..def1bb7 100644 (file)
@@ -26,6 +26,7 @@ agl-passenger::1002:1002:::
 messagebus::994:994:::
 afm::992:992:::
 systemd-timesync::988:988:::
+systemd-coredump::888:888:::
 pulse::991:991:::
 bind::987:987:::
 trinity::985:985:::
index f64ca8c..815fed8 100644 (file)
@@ -24,3 +24,6 @@ FILES_${PN} += "${sysconfdir}/e2fsck.conf "
 
 # SPEC-737: connmand also has a NTP client which races with systemd-timesyncd
 PACKAGECONFIG_remove = "timesyncd"
+
+# Enable systemd-coredump when agl-devel is set on
+PACKAGECONFIG_append_agl-devel = " coredump"