[Work-around] Update recipe for ImageMagick to avoid bitbake error 23/16223/4
authorTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
Wed, 22 Aug 2018 04:08:59 +0000 (04:08 +0000)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Thu, 23 Aug 2018 12:07:25 +0000 (12:07 +0000)
At www.imagemagick.org/download, tarball archives of old patchsets are deleted
when a new patchset is created. This causes error when do_fetch().

Offical source repository is in github, so SRC_URI can be set to pull from there.
Unfortunately, github repository has tags only after 6.9.5-4.
Therefore, updated to the latest stable, 6.9.10-10.

For meta-agl/meta-agl-demo, ImageMagick is not mandatory component,
but optee inside Renesas BSP requires it (and python-wand).

Upstream optee already remove these dependency, so this is
just work-around until meta-renesas-rcar-gen3 will be updated.

Change-Id: I1767e2d7588a35d75009843312c484d3d63553ae
Signed-off-by: Tadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
meta-agl-bsp/meta-rcar-gen3/recipes-support/imagemagick/imagemagick_6.9.10.bb [moved from meta-agl-bsp/meta-rcar-gen3/recipes-support/imagemagick/imagemagick_6.9.2.bb with 91% similarity]

@@ -1,20 +1,17 @@
 SUMMARY = "ImageMagick is an image convertion tools"
 SECTION = "console/utils"
 LICENSE = "ImageMagick"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=0887b670be7ef0c3cb37092b64d57514"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=4c223567f4c3b26a08c56aa59b346ca5"
 # FIXME: There are many more checked libraries. All should be added or explicitly disabled to get consistent results.
 DEPENDS = "lcms bzip2 jpeg libpng librsvg tiff zlib fftw freetype"
 
 # Important note: tarballs for all patchsets within a version are deleted when
 # a new pachset is created. To avoid multiple patches for each patchset, try to
 # update to the last pachset of a version
-PATCHSET = "0"
-SRC_URI = "http://www.imagemagick.org/download/releases/ImageMagick-${PV}-${PATCHSET}.tar.xz \
+PATCHSET = "10"
+SRC_URI = "git://github.com/ImageMagick/ImageMagick6.git;protocol=https;tag=${PV}-${PATCHSET} \
 "
-SRC_URI[md5sum] = "99471c8c3f38c9264faf5c4ca7a31287"
-SRC_URI[sha256sum] = "07a2de28f7f9ab888ef47c02eb7e10cc3e0dd0e9797c5d71d6e71d19f842399e"
-
-S = "${WORKDIR}/ImageMagick-${PV}-${PATCHSET}"
+S = "${WORKDIR}/git"
 
 inherit autotools pkgconfig update-alternatives