Make the mode configurable at build time for the waltham transmitter 09/26609/4
authorAnusha Gugale <external.agogale@jp.adit-jv.com>
Thu, 2 Sep 2021 05:49:06 +0000 (11:19 +0530)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Mon, 27 Sep 2021 07:22:28 +0000 (07:22 +0000)
- Create a TRANSMITTER_OUTPUT_MODE variable with a known default
- Use this to update the transmitter-output.cfg fragment
- Users can redefine this variable based on their needs
- While at it do the same for HOST and PORT

Bug-AGL: SPEC-4030

Signed-off-by: Anusha Gugale <external.agogale@jp.adit-jv.com>
Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Change-Id: I32374186bdce3171a1f7ad4026e10c6448edaec6
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/26609
Tested-by: Jenkins Job builder account
ci-image-build: Jenkins Job builder account
ci-image-boot-test: Jenkins Job builder account

meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb
meta-agl-core/recipes-graphics/wayland/weston-ini-conf/transmitter-output.cfg.in [moved from meta-agl-core/recipes-graphics/wayland/weston-ini-conf/transmitter-output.cfg with 100% similarity]

index 8842a5a..c635d7b 100644 (file)
@@ -10,7 +10,7 @@ SRC_URI = " \
        file://hdmi-a-1-180.cfg \
        file://hdmi-a-1-270.cfg \
        file://remote-output.cfg \
-       file://transmitter-output.cfg \
+       file://transmitter-output.cfg.in \
        file://virtual-0.cfg \
        file://virtual-180.cfg \
        file://virtual-270.cfg \
@@ -31,6 +31,19 @@ WESTON_FRAGMENTS = "core shell ${WESTON_DISPLAYS}"
 # On-target weston.ini directory
 weston_ini_dir = "${sysconfdir}/xdg/weston"
 
+# Options for the user to change in local.conf
+# e.g. TRANSMITTER_OUTPUT_MODE = "1080x1488"
+TRANSMITTER_OUTPUT_MODE ??= "640x720@30"
+TRANSMITTER_OUTPUT_HOST ??= "192.168.20.99"
+TRANSMITTER_OUTPUT_PORT ??= "5005"
+
+do_configure() {
+    sed -e "s#mode=.*#mode=${TRANSMITTER_OUTPUT_MODE}#" \
+        -e "s#host=.*#host=${TRANSMITTER_OUTPUT_HOST}#" \
+        -e "s#port=.*#port=${TRANSMITTER_OUTPUT_PORT}#" \
+        ${WORKDIR}/transmitter-output.cfg.in  > ${WORKDIR}/transmitter-output.cfg
+}
+
 do_compile() {
     # Put all of our cfg files together for a default portrait
     # orientation configuration