raspberrypi: Upgrade to u-boot v2021.07 for latest 4B boards 24/26624/4
authorHiroyuki Ishii <ishii.hiroyuki002@jp.panasonic.com>
Thu, 9 Sep 2021 01:43:22 +0000 (10:43 +0900)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Wed, 22 Sep 2021 15:32:44 +0000 (15:32 +0000)
The latest revision (1.4) of raspberry pi 4B board can't be boot
by using current version of u-boot with showing "No partition
table" message. This can be related to the change of DMA hardware
on the new SoC (2711ZPKFSB06C0T) and we've confirmed upgrading
u-boot to newer version than 2021.04 which has several fixes
around Broadcom's DMA solves the issue. Also, we'd like to choice
2021.07 rather than 2021.04 since it's going to be supported for
longer in yocto project.

Bug-AGL: SPEC-4072

Signed-off-by: Hiroyuki Ishii <ishii.hiroyuki002@jp.panasonic.com>
Change-Id: I7cbca889a93909e15ab04263c6d7d635a839bd56
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/26624
Tested-by: Jenkins Job builder account
ci-image-build: Jenkins Job builder account
ci-image-boot-test: Jenkins Job builder account
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Reviewed-by: Scott Murray <scott.murray@konsulko.com>
meta-agl-bsp/conf/include/agl_raspberrypi4.inc
meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/u-boot-2021.07.inc [new file with mode: 0644]
meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/u-boot-tools_2021.07.bb [new file with mode: 0644]
meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/u-boot_2021.07.bb [new file with mode: 0644]

index 09cdfa7..5a0e89e 100644 (file)
@@ -30,6 +30,6 @@ IMAGE_INSTALL:append = " ${@bb.utils.contains('AGL_XEN_WANTED', '1', 'xen-tools
 # Add xen-raspberry binary to boot files
 IMAGE_BOOT_FILES:append = " ${@bb.utils.contains('AGL_XEN_WANTED','1', 'xen-${MACHINE}', '',d)}"
 
-PREFERRED_VERSION_u-boot = "2020.10"
-PREFERRED_VERSION_u-boot-tools = "2020.10"
+PREFERRED_VERSION_u-boot = "2021.07"
+PREFERRED_VERSION_u-boot-tools = "2021.07"
 UBOOT_MACHINE:rpi = "rpi_arm64_config"
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/u-boot-2021.07.inc b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/u-boot-2021.07.inc
new file mode 100644 (file)
index 0000000..abf7474
--- /dev/null
@@ -0,0 +1,3 @@
+SRC_URI = "git://git.denx.de/u-boot.git"
+SRCREV = "840658b093976390e9537724f802281c9c8439f5"
+LIC_FILES_CHKSUM = "file://Licenses/README;md5=5a7450c57ffe5ae63fd732446b988025"
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/u-boot-tools_2021.07.bb b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/u-boot-tools_2021.07.bb
new file mode 100644 (file)
index 0000000..a963d3f
--- /dev/null
@@ -0,0 +1,2 @@
+require recipes-bsp/u-boot/u-boot-tools_2020.01.bb
+require u-boot-2021.07.inc
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/u-boot_2021.07.bb b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/u-boot_2021.07.bb
new file mode 100644 (file)
index 0000000..2077262
--- /dev/null
@@ -0,0 +1,2 @@
+require recipes-bsp/u-boot/u-boot_2020.01.bb
+require u-boot-2021.07.inc