meta-agl-bsp: add fix for intermittent failures in arm-trusted-firmware 31/27431/2
authorScott Murray <scott.murray@konsulko.com>
Fri, 29 Apr 2022 16:44:27 +0000 (12:44 -0400)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tue, 3 May 2022 21:36:16 +0000 (21:36 +0000)
Add a work around in the arm-trusted-firmware bbappend for
meta-rcar-gen3 to fix intermittent failures due to a bug in the
upstream recipe where it is dependent on something else happening
to have run first and creating DEPLOY_DIR_IMAGE.

Bug-AGL: SPEC-4343

Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Change-Id: Ibe43bdb0cf1b525e30ada758e12b687f5dda0d3f
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/27431
ci-image-build: Jenkins Job builder account
Reviewed-by: Vasyl Vavrychuk <vasyl.vavrychuk@opensynergy.com>
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
meta-agl-bsp/meta-rcar-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_git.bbappend

index 4ba36ca..212c661 100644 (file)
@@ -3,3 +3,9 @@ FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
 SRC_URI:append = " \
     file://0001-Boot-Normal-World-in-EL2.patch \
 "
+
+do_ipl_opt_deploy:prepend () {
+    # Work around bug in BSP recipe, it can fail if nothing else has
+    # happened to run first and create the directory.
+    install -d ${DEPLOY_DIR_IMAGE}
+}