meta-agl-bsp: fix building weston for rcar3 nogfx machines 30/27430/2
authorScott Murray <scott.murray@konsulko.com>
Fri, 29 Apr 2022 16:36:26 +0000 (12:36 -0400)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tue, 3 May 2022 21:36:16 +0000 (21:36 +0000)
Work around use of obsolete Weston backend-fbdev in meta-rcar-gen3
when building without the proprietary driver stack.  Masking out the
weston_%.bbappend seems the simplest approach for now, as forcing
USE_GLES = "1" to disable the adding of -Dbackend-default="fbdev" to
EXTRA_OEMESON triggers adding "libgbm" to DEPENDS, which breaks due
to that being a component specific to the proprietary stack we are
explicitly disabling.  If the "libgbm" usage in the bbappend was
instead "virtual/libgbm" as is now used in poky, it might be possible
to just tweak PREFERRED_PROVIDER_virtual/libgbm = "mesa".

Bug-AGL: SPEC-4343

Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Change-Id: I603a9c4744befb97513808714cedd3e21664525f
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/27430
ci-image-build: Jenkins Job builder account
Reviewed-by: Vasyl Vavrychuk <vasyl.vavrychuk@opensynergy.com>
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
meta-agl-bsp/conf/include/agl_h3-salvator-x-nogfx.inc
meta-agl-bsp/conf/include/agl_h3ulcb-nogfx.inc
meta-agl-bsp/conf/include/agl_m3ulcb-nogfx.inc

index 1ee0fe5..455a368 100644 (file)
@@ -9,6 +9,17 @@ BBMASK += "gles-user-module|kernel-module-gles|wayland-kms|libgbm"
 # Mask MMP recipes
 BBMASK += "kernel-module-uvcs-drv|omx-user-module"
 
+# Work around use of obsolete Weston backend-fbdev in meta-rcar-gen3
+# when building without the proprietary driver stack.  Masking out the
+# weston_%.bbappend seems the simplest approach for now, as forcing
+# USE_GLES = "1" to disable the adding of -Dbackend-default="fbdev" to
+# EXTRA_OEMESON triggers adding "libgbm" to DEPENDS, which breaks due
+# to that being a component specific to the proprietary stack we are
+# explicitly disabling.  If the "libgbm" usage in the bbappend was
+# instead "virtual/libgbm" as is now used in poky, it might be possible
+# to just tweak PREFERRED_PROVIDER_virtual/libgbm = "mesa".
+BBMASK += "meta-rcar-gen3/recipes-graphics/wayland/weston_%.bbappend"
+
 # do use software rendering to display the compositor
 # used for images w/o binary-only driver
 WESTON_USE_PIXMAN = "1"
index 07a93df..5f288fc 100644 (file)
@@ -9,8 +9,16 @@ BBMASK += "gles-user-module|kernel-module-gles|wayland-kms|libgbm"
 # Mask MMP recipes
 BBMASK += "kernel-module-uvcs-drv|omx-user-module"
 
-# Workaround for SPEC-3706 - versioned bbappends and upstream moved on to 1.16.3
-BBMASK += "meta-renesas/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-.*1.16.2\.bbappend"
+# Work around use of obsolete Weston backend-fbdev in meta-rcar-gen3
+# when building without the proprietary driver stack.  Masking out the
+# weston_%.bbappend seems the simplest approach for now, as forcing
+# USE_GLES = "1" to disable the adding of -Dbackend-default="fbdev" to
+# EXTRA_OEMESON triggers adding "libgbm" to DEPENDS, which breaks due
+# to that being a component specific to the proprietary stack we are
+# explicitly disabling.  If the "libgbm" usage in the bbappend was
+# instead "virtual/libgbm" as is now used in poky, it might be possible
+# to just tweak PREFERRED_PROVIDER_virtual/libgbm = "mesa".
+BBMASK += "meta-rcar-gen3/recipes-graphics/wayland/weston_%.bbappend"
 
 # do use software rendering to display the compositor
 # used for images w/o binary-only driver
index d2c4c05..31d99c3 100644 (file)
@@ -9,12 +9,20 @@ BBMASK += "gles-user-module|kernel-module-gles|wayland-kms|libgbm"
 # Mask MMP recipes
 BBMASK += "kernel-module-uvcs-drv|omx-user-module"
 
-DISTRO_FEATURES:append = "${@bb.utils.contains('AGL_XEN_WANTED', '1', ' xen', '', d)}"
-IMAGE_INSTALL:append = "${@bb.utils.contains('AGL_XEN_WANTED', '1', ' xen-base xen-mkimage', '', d)}"
-
-# Workaround for SPEC-3706 - versioned bbappends and upstream moved on to 1.16.3
-BBMASK += "meta-renesas/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-.*1.16.2\.bbappend"
+# Work around use of obsolete Weston backend-fbdev in meta-rcar-gen3
+# when building without the proprietary driver stack.  Masking out the
+# weston_%.bbappend seems the simplest approach for now, as forcing
+# USE_GLES = "1" to disable the adding of -Dbackend-default="fbdev" to
+# EXTRA_OEMESON triggers adding "libgbm" to DEPENDS, which breaks due
+# to that being a component specific to the proprietary stack we are
+# explicitly disabling.  If the "libgbm" usage in the bbappend was
+# instead "virtual/libgbm" as is now used in poky, it might be possible
+# to just tweak PREFERRED_PROVIDER_virtual/libgbm = "mesa".
+BBMASK += "meta-rcar-gen3/recipes-graphics/wayland/weston_%.bbappend"
 
 # do use software rendering to display the compositor
 # used for images w/o binary-only driver
 WESTON_USE_PIXMAN = "1"
+
+DISTRO_FEATURES:append = "${@bb.utils.contains('AGL_XEN_WANTED', '1', ' xen', '', d)}"
+IMAGE_INSTALL:append = "${@bb.utils.contains('AGL_XEN_WANTED', '1', ' xen-base xen-mkimage', '', d)}"