pipewire: Update PipeWire to v0.3.83 and WirePlumber to v0.4.15 88/29388/3
authorAshok Sidipotu <ashok.sidipotu@collabora.com>
Fri, 27 Oct 2023 10:25:01 +0000 (15:55 +0530)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tue, 7 Nov 2023 21:42:45 +0000 (21:42 +0000)
Highlights of Pipewire.
- Add BAP broadcast source and sink support.
- Vulkan DMA buf support was merged.
- Fix a leak in the SBC codecs for SCO.
- More bugfixes and improvements.
- IRQ based scheduling in ALSA was improved and enabled by default for
  Pro-Audio profile. It will also link the pcms together to get lower
  latency. This now matches what JACK does and results in equal latency
  for Pro-Audio profiles.
- A new L permission was added to make it possible to force a link between
  nodes even when the nodes can't see each other.
- Libcamera and v4l2 devices now have properties so that duplicates can be
  filtered out by the session manager.
- Improve RAOP compatibility.
- ALSA hires timestamps are now disabled by default.

Highlights of Wireplumber.
- A new "DSP policy" module has been added; its purpose is to automatically
  load a filter-chain when a certain hardware device is present, so that
  audio always goes through this software DSP before reaching the device.
  This is mainly to support Apple M1/M2 devices, which require a software
  DSP to be always present
- WpImplModule now supports loading module arguments directly from a SPA-JSON
  config file; this is mainly to support DSP configuration for Apple M1/M2
  and will likely be reworked for 0.5

Bug-AGL: SPEC-4940
Change-Id: I7caa7b08686704cc94be896bcd0c2269ab3c8133
Signed-off-by: Ashok Sidipotu <ashok.sidipotu@collabora.com>
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/29388
Tested-by: Jenkins Job builder account
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
ci-image-boot-test: Jenkins Job builder account
ci-image-build: Jenkins Job builder account

meta-pipewire/recipes-multimedia/pipewire/pipewire_0.3.83.bb [moved from meta-pipewire/recipes-multimedia/pipewire/pipewire_0.3.67.bb with 97% similarity]
meta-pipewire/recipes-multimedia/pipewire/pipewire_0.3.83.bbappend [moved from meta-pipewire/recipes-multimedia/pipewire/pipewire_0.3.67.bbappend with 100% similarity]
meta-pipewire/recipes-multimedia/wireplumber/wireplumber_git.bb

@@ -20,8 +20,8 @@ SECTION = "multimedia"
 
 DEPENDS = "dbus"
 
-# v0.3.67
-SRCREV = "26623ff8cb3c9ba774537379a1835c5efb0d5159"
+# v0.3.83
+SRCREV = "6fd7f39dbec9c3a65aa2de0123c6bfbda7c53a85"
 SRC_URI = "git://gitlab.freedesktop.org/pipewire/pipewire.git;branch=master;protocol=https"
 
 S = "${WORKDIR}/git"
@@ -238,6 +238,10 @@ FILES:${PN} = " \
     ${bindir}/pipewire-avb \
     ${datadir}/pipewire/pipewire-aes67.conf \
     ${bindir}/pipewire-aes67 \
+    ${datadir}/pipewire/pipewire.conf.avail \
+    ${datadir}/pipewire/pipewire-pulse.conf.avail \
+    ${datadir}/pipewire/client-rt.conf.avail \
+    ${datadir}/pipewire/client.conf.avail \
     ${sysconfdir}/security/limits.d \
 "
 
index 1caac0b..e5c8253 100644 (file)
@@ -14,14 +14,14 @@ DEPENDS = "glib-2.0 glib-2.0-native pipewire lua"
 SRC_URI = "\
     git://gitlab.freedesktop.org/pipewire/wireplumber.git;protocol=https;branch=master \
 "
-# v0.4.14
-SRCREV = "6d0c7f7b7f484b3cd2aaf2e2b3cc902c095b4946"
+# v0.4.15
+SRCREV = "d67b48e595cb4612fd7fd47f97df6b8883ef7f60"
 
 # patches to be able to compile with lower version of meson that is available in AGL.
 SRC_URI += "\
 "
 
-PV = "0.4.14"
+PV = "0.4.15"
 S  = "${WORKDIR}/git"
 
 WPAPI="0.4"
@@ -59,6 +59,7 @@ FILES:${PN} = "\
     ${bindir}/wpexec \
     ${libdir}/wireplumber-${WPAPI}/* \
     ${datadir}/wireplumber/scripts/* \
+    ${datadir}/zsh/* \
     ${systemd_system_unitdir}/* \
 "
 RPROVIDES:${PN} += "virtual/pipewire-sessionmanager"