Add new recipe for linpack 73/5473/3
authorYannick Gicquel <yannick.gicquel@iot.bzh>
Thu, 31 Mar 2016 16:05:08 +0000 (18:05 +0200)
committerGerrit Code Review <gerrit@172.30.200.200>
Sun, 1 May 2016 21:40:30 +0000 (21:40 +0000)
linpack benchmark license is BSD, from lapack-forum:
http://icl.cs.utk.edu/lapack-forum/archives/lapack/msg00301.html

Change-Id: I7093f98102e9cb3c61aad3fa9c8ced8693ff67a1
Signed-off-by: Yannick Gicquel <yannick.gicquel@iot.bzh>
meta-ivi-common/recipes-test/linpack/linpack.bb [new file with mode: 0644]

diff --git a/meta-ivi-common/recipes-test/linpack/linpack.bb b/meta-ivi-common/recipes-test/linpack/linpack.bb
new file mode 100644 (file)
index 0000000..7ac1eb9
--- /dev/null
@@ -0,0 +1,21 @@
+SUMMARY = "Linpack benchmark"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://${S}/${PN}/linpack.c;md5=076f1fd8d313056103f98d4253862eae"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/qa-test-misc;protocol=https;branch=master"
+SRCREV = "920cae73a918d1f516113b0ae967be3ecaba86ef"
+
+inherit autotools
+
+S = "${WORKDIR}/git"
+
+# configure script is not delivered, only a makefile.
+do_configure() {
+    mkdir -p ${B}
+    rsync -a ${S}/${PN}/* ${B}
+}
+
+do_install() {
+    install -d ${D}${bindir}
+    install -m 0755 ${B}/linpack ${D}${bindir}
+}