Add new recipe for linpack
[AGL/meta-agl.git] / meta-ivi-common / recipes-test / linpack / linpack.bb
1 SUMMARY = "Linpack benchmark"
2 LICENSE = "BSD"
3 LIC_FILES_CHKSUM = "file://${S}/${PN}/linpack.c;md5=076f1fd8d313056103f98d4253862eae"
4
5 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/qa-test-misc;protocol=https;branch=master"
6 SRCREV = "920cae73a918d1f516113b0ae967be3ecaba86ef"
7
8 inherit autotools
9
10 S = "${WORKDIR}/git"
11
12 # configure script is not delivered, only a makefile.
13 do_configure() {
14     mkdir -p ${B}
15     rsync -a ${S}/${PN}/* ${B}
16 }
17
18 do_install() {
19     install -d ${D}${bindir}
20     install -m 0755 ${B}/linpack ${D}${bindir}
21 }