Provide updated Wayland-IVI-Extension. 19/5619/6
authorAndre Moreira Magalhaes (andrunko) <andre.magalhaes@collabora.co.uk>
Wed, 13 Apr 2016 02:58:54 +0000 (23:58 -0300)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Fri, 6 May 2016 21:45:53 +0000 (21:45 +0000)
This change adds support for Wayland IVI Extension 1.9.1 (latest stable release).

Wayland-IVI-Extension provides an additional shell plugin for IVI-Shell, along with
command-line tools and demonstration applications.

More info at http://projects.genivi.org/wayland-ivi-extension.

Change-Id: Icd193af70b226745b9316d18dc239909703d7bda
Signed-off-by: Andre Moreira Magalhaes (andrunko) <andre.magalhaes@collabora.co.uk>
meta-ivi-common/recipes-graphics/wayland/wayland-ivi-extension_1.9.1.bb [new file with mode: 0644]

diff --git a/meta-ivi-common/recipes-graphics/wayland/wayland-ivi-extension_1.9.1.bb b/meta-ivi-common/recipes-graphics/wayland/wayland-ivi-extension_1.9.1.bb
new file mode 100644 (file)
index 0000000..eea9627
--- /dev/null
@@ -0,0 +1,24 @@
+SUMMARY = "Wayland IVI Extension"
+DESCRIPTION = "GENIVI Layer Management API based on Wayland IVI Extension"
+HOMEPAGE = "http://projects.genivi.org/wayland-ivi-extension"
+BUGTRACKER = "http://bugs.genivi.org/enter_bug.cgi?product=Wayland%20IVI%20Extension"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=176cedb32f48dd58f07e0c1c717b3ea4"
+
+DEPENDS = "weston"
+
+SRC_URI = "git://git.projects.genivi.org/${PN}.git \
+          "
+SRC_URI_append_wandboard = "file://wandboard_fix_build.patch"
+
+SRCREV = "44598504503eea5ac7f94c88477a5a78bda01f30"
+
+S = "${WORKDIR}/git"
+
+inherit cmake autotools
+
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[ivi-share] = "-DIVI_SHARE=ON,-DIVI_SHARE=OFF,libgbm libdrm"
+
+FILES_${PN} += "${libdir}/weston/*"
+FILES_${PN}-dbg += "${libdir}/weston/.debug/*"