Provide updated Wayland-IVI-Extension.
[AGL/meta-agl.git] / meta-ivi-common / recipes-graphics / wayland / wayland-ivi-extension_1.9.1.bb
1 SUMMARY = "Wayland IVI Extension"
2 DESCRIPTION = "GENIVI Layer Management API based on Wayland IVI Extension"
3 HOMEPAGE = "http://projects.genivi.org/wayland-ivi-extension"
4 BUGTRACKER = "http://bugs.genivi.org/enter_bug.cgi?product=Wayland%20IVI%20Extension"
5 LICENSE = "Apache-2.0"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=176cedb32f48dd58f07e0c1c717b3ea4"
7
8 DEPENDS = "weston"
9
10 SRC_URI = "git://git.projects.genivi.org/${PN}.git \
11           "
12 SRC_URI_append_wandboard = "file://wandboard_fix_build.patch"
13
14 SRCREV = "44598504503eea5ac7f94c88477a5a78bda01f30"
15
16 S = "${WORKDIR}/git"
17
18 inherit cmake autotools
19
20 PACKAGECONFIG ??= ""
21 PACKAGECONFIG[ivi-share] = "-DIVI_SHARE=ON,-DIVI_SHARE=OFF,libgbm libdrm"
22
23 FILES_${PN} += "${libdir}/weston/*"
24 FILES_${PN}-dbg += "${libdir}/weston/.debug/*"