raspberrypi: Upgrade to u-boot v2020.10 37/25937/3
authorPaul Barker <pbarker@konsulko.com>
Thu, 21 Jan 2021 18:17:51 +0000 (18:17 +0000)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tue, 26 Jan 2021 11:02:24 +0000 (11:02 +0000)
The newer u-boot version supports the network interface on the rpi4,
allowing us to do things like DHCP boot.

Also switch to the preferred "rpi_arm64" u-boot config.

Bug-AGL: SPEC-2983

Signed-off-by: Paul Barker <pbarker@konsulko.com>
Change-Id: I0dff4779f98c7ce6394efd9feb58b7f2a8933296
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/25937
Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
ci-image-boot-test: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
meta-agl-bsp/conf/include/agl_raspberrypi4.inc
meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/u-boot-2020.10.inc [new file with mode: 0644]
meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/u-boot-tools_2020.10.bb [new file with mode: 0644]
meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/u-boot_2020.10.bb [new file with mode: 0644]

index ae302aa..c44d44f 100644 (file)
@@ -26,3 +26,7 @@ IMAGE_INSTALL_append = " ${@bb.utils.contains('AGL_XEN_WANTED', '1', 'xen-tools
 
 # Add xen-raspberry binary to boot files
 IMAGE_BOOT_FILES_append = " ${@bb.utils.contains('AGL_XEN_WANTED','1', 'xen-${MACHINE}', '',d)}"
+
+PREFERRED_VERSION_u-boot = "2020.10"
+PREFERRED_VERSION_u-boot-tools = "2020.10"
+UBOOT_MACHINE_rpi = "rpi_arm64_config"
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/u-boot-2020.10.inc b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/u-boot-2020.10.inc
new file mode 100644 (file)
index 0000000..27f4609
--- /dev/null
@@ -0,0 +1,3 @@
+SRC_URI = "git://git.denx.de/u-boot.git"
+SRCREV = "050acee119b3757fee3bd128f55d720fdd9bb890"
+LIC_FILES_CHKSUM = "file://Licenses/README;md5=5a7450c57ffe5ae63fd732446b988025"
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/u-boot-tools_2020.10.bb b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/u-boot-tools_2020.10.bb
new file mode 100644 (file)
index 0000000..2d9d769
--- /dev/null
@@ -0,0 +1,2 @@
+require recipes-bsp/u-boot/u-boot-tools_2020.01.bb
+require u-boot-2020.10.inc
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/u-boot_2020.10.bb b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/u-boot_2020.10.bb
new file mode 100644 (file)
index 0000000..0d96757
--- /dev/null
@@ -0,0 +1,2 @@
+require recipes-bsp/u-boot/u-boot_2020.01.bb
+require u-boot-2020.10.inc